SSL error

When requesting the SSL certificate, an error message appears some time later, even though everything is green and written ready.

“SSL certificate error: Let’s Encrypt encountered an error verifying the DNS settings of your domain name. Please double check your nameserver settings and try again later.”

And I’m sure the nameservers até correct.


Please search the forum before posting as there is a few valid answers to this question.

Please try setting the nameservers on your domain again, and then wait 72 hours for the DNS to update.


I’m not sure why it failed so many times. But note that on the CNAME records page, it also says that the settings can take up to 24 hours to take effect.

And it should be noted that our CNAME checker doesn’t always perfectly match what Let’s Encrypt sees on their end.

But I see that three hours after creation you did succeed to get a certificate.


I did it, but there is a problem, when I type the website link, it automatically loads at “http://” and is as if it were unsafe. But when I type the link with “https://” it loads with the certificate, and a padlock appears. However, nobody types “https://” before the links, so as soon as someone enters the site, they will not be safe. How do I get the site to open automatically at “https://” ? Or if there is a way to leave the “http://” link with the certificate too?

You will have to force HTTPS, and this article helps you do that:


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.