SSL Error

Hello everyone,

i’ve installed a ssl certificate in At the beginning it worked perfectly, but after a while it shows “The certificate is untrusted”.

It goes back to the self-signed one without me doing anything.


I am getting same problem on my domain. I need help too :slight_smile:

I just checked your website and I see a green lock from a Let’s Encrypt certificate.

Note that some browsers, notably Google Chrome, can cache old SSL certificates for a while. So if a certain device showed an SSL error before, it may take a while for the devices to pick up the newly installed, valid SSL certificate.

Thanks, it’s now working as I expect!

It happened again. I don’t know why is this happening, I just entered the website and it says Connection Untrusted. I did not make any changes in cPanel.

I can’t upload image correctly.

Is there any consistency in the devices and browsers where you see this error? Could it be that just your phone has the old, invalid SSL certificate rather than the new one you installed?

No. When it happens, it’s in all devices.

By the way, I’ve created another website, and the ssl error, when it happens, it’s in all devices, in the two websites I’ve created. I have tested the same certificate provider in a website running on my computer, and it works fine. I think there’s a bug in the ssl manager.

It could be that there is a bug in the SSL manager. But then what do you suppose the bug is? I can access your website without any SSL errors. And I tried a few different SSL validators, and they all say the SSL certificate is invalid.

For reference, these are the checkers I used:

Seeing how your mobile phone seems to be the only place where the certificate is not accepted, could it be possible that this is an issue with your phone, or your phone’s network, instead?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.