SSL Error With Cluoudflare

** epiz_27507482 |**

So, Basically, I have configured Cloudflare for my website, and also set an SSL Encryption as well, but the problem is few days after I set the SSL/TLS for my website, The connection is just not working, If I try to connect to the SSL connection( It just shows an error(This site can’t provide a secure connection, sent an invalid response) but the HTTP connection is still working fine…I’m also using the universal SSL certificate that Cloudflare Provided.

You need to proxy the the domain in DNS section.
Click on the gray cloud to make it orange, and you are good to go




SSL full mode also requires SSL cert on the origin server.
Use InfintyFree SSL tool to obtain and install SSL cert.


If ur using Infityfree SSl Tool, then enable Full (Strict) because it uses Let’s Encrypt which is a trusted CA.

uh, I did that, but it’s still not working…

Set it to flexible mode in SSL settings(Cloudflare)

1 Like

Ok, It’s Working, Thanks!


Glad that we helped you.

1 Like

It can take some time to take effect due to DNS propagation. At least five minutes, maybe more.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.