Website :


I use : Firefox

I used cloudflare with wordpress and thought I messed up something so I uninstalled wordpress are removed clouflare, but I still get this error.

Please help.

Is there a way to reset everything and start from scratch?

EDIT : I’m now using Let’s encrypt and now can access my site. But for some reason when I set my sub domain in the CNAME records it doesn’t get recognized by the SSL tab in the client area.

You can remove your HTTPS redirect. But please keep in mind that your browser will remember the HTTPS redirect and will try to connect you over HTTPS again. You can bypass that with private browsing mode.

Is this still an issue? I see you’ve successfully acquired a certificate for a subdomain.

I re-added the my domains, and instead of cloudflare I used Let’s Encrypt. I use one of my subdomain to redirect so its not a big problem and I have aquired a certificate. Thanks for your concern.

I just have one question: Will I be able to use Wordpress with Let’s Encrypt? Since when i did it with cloudflare and really simple ssl I got a mixed content error. And firefox would say parts of the website were not secure. Can I configure these via the plugin like I did with cloudflare?
such as HTTPS rewrites, and HSTS and Always use HTTPS?


Hey @Admin, If I use the Let’s encrypt certificate and try to set it for HSTS preload, it says I have an incomplete cert chain uses an incomplete or invalid certificate chain.”
and if try to set .htaccess 301 redirect with Really Simple SSL, it gives me an error as well.

How do I fix this?

For some reason when I visit , I get redirected like, 3 or 4 times. It goes to and then to and due to this for some reason I’m not eligible for my site to be preloaded.

The mixed content error is a configuration issue in your website, not a problem with the certificate itself. You need to make sure that all URLs on all pages use HTTPS and you won’t have any mixed content / not secure warnings.

HSTS and HTTPS redirects can be enforced from your website code and/or .htaccess rules. There may be WordPress plugins to help with that.

Automatic HTTPS Rewrites is a horrible system which should be avoided at all costs. Properly configured websites don’t need it, and it tends to cause very strange issues if you do use it. You don’t want to use this feature, with or without Cloudflare.

Free hosting doesn’t support uploading CA chains. That’s a premium only feature. It’s not necessary in most cases, but it may prevent the use of HSTS.

What error?

1 Like

Okay so after this it broke my website it was in a redirect loop so I deleted the certs and switched back to cloudflare which fixed it… temporarily. Suddenly, it got me into a redirect loop. So I paused cloudflare and eve though I deleted my Let’s Encrypt Cert. It still shows up and I checked it with an ssl checker and multiple devices to make sure it wasn’t a cache thing.

I’m just idek anymore, I wanna stay with cloudflare but when I enable cloudflare the certificates put me in a redirect loop. But I clearly deleted the Lets encrypt certificats from c-panel so Idk why they aren;t going away so I can re-enable cloudflare.

Idk what to do at this point.

Take a look at it shows Let’s Encrypt but I’ve deleted the cert from cpanel and removed the cname records as well. But why is it still there?

It loads with lets encrypt ssl. Your only content is directory listing

A post was merged into an existing topic: Deleted SSL cert from cPanel but still shows up on my website?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.