SSL Error Code # 4

Username epiz_28645791 Website URL:

(please specify the website or account you are asking about)

Error Message

SSL error code #4
(please share the FULL error message you see)

Other Information

When attempting to renew the SSL certificate (Let’s Encrypt) for my website, I continued to receive the error and was unable to figure out what I should do.
(other information and details relevant to your question)

Hmm, this is very strange.

Did you setup a TXT record for in Cloudflare? If so, can you please remove it? And make sure the CNAME record is set to “DNS Only”?

For some reason Cloudflare returns it’s own TXT record for, which is different from the TXT record that we put on for your domain.

1 Like

I’ve tried to repropagate the DNS records in Cloudflare.
How long does it take Let’s Encrypt to find the new DNS records?

Up to 72 hours for DNS changes.

1 Like

I checked your DNS records again and they seem even worse than before. It looks like you change the previous record from a CNAME record to a TXT record.

Please delete ALL records of type TXT for the subdomain _acme-challenge. And then add a record with type CNAME that points to the value shown in the client area.

Up to 24 hours. And Cloudflare’s nameservers are fast, so it’s probably a lot less than that.


I tried again after updating the DNS records and I’m still receiving code #4
All of the TXT records have been removed and have been replaced by CNAME records.

There is still a TXT record on your domain. You must remove this to get your SSL certificate.

You can check whether you actually removed it with any DNS lookup tool, like this: Dig web interface - online dns lookup tool

If you set it up correctly, this DNS lookup should not return any TXT records.


Thank you, this worked @Admin and @Greenreader9

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.