SSL Error + 502

Hi there! Good morning, I saw today some big websites has problems with 502 (my website as well but when I trie to install an SSL certificate it says ‘The certificate you have entered does not match the current private key.’ and 'The certificate uploaded is NOT for the domain name (CloudFlare Origin Certificate was seen) .
’ and I know that the certificate is correct but I can’t even install it on my website (Also as I said has error 502) please help! :{ @Admin


Please make sure you are getting the SSL from

1 Like

I tried with two certificates, the first one was a cloudflare SSL certificate (it didn’t work) and then I tried with a free SSL certificate from Let’s encrypt that I got from Infinityfree (it didn’t work as well)

The Origin Certificates indeed do not work here.

Uploading the certificate from Let’s Encrypt doesn’t work right now because the private key doesn’t match. Please copy the private key from the client area first, paste it in the control panel and click Upload Key. Then, do the same for the certificate.

It’s important that the private key is uploaded before you upload the certificate, and that the private key and the certificate match.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.