SSL CSR key not updating

My website is

I bought an SSL cert from goDaddy and tryed to upload it. The Private key and certificate upload no problem, but the CSR is no changing. Every time i paste in the new CSR and click the upload button, it go’s back to the old CSR.
I tried both upload buttons (one for the key and one for the Cert).
I tried clicking generate and getting a new Key and CSR, then overriding them with the correct key & CSR that i have from goDaddy, but the CSR still reverts back to the generated CSR, but the key is updated correctly.
Am I doing something wrong?
The CSR I have from goDaddy is a lot smaller, only 895 characters compared to the 1078 characters in the generated one. Is this valid?

A CSR is the text you sent to an SSL vendor to get an SSL certificate for the private key you have. Once you have the SSL certificate, the CSR is basically useless.

The CSR box in our panel is only used if you generate a private key from our panel, and want to get a matching certificate. There is no button to upload a CSR, because a CSR is uploaded to an SSL vendor, not to a hosting provider.

So you can just delete the CSR and forget about it. You basically can’t use it for anything anymore. Any CSR currently present on your account also doesn’t affect the SSL status of your account.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.