SSL certificate renew new problems

My website is: oneirofono .gr

What I’m seeing is: SSL certificate error: Your domain’s nameservers didn’t respond correctly. Please make sure you are only using and nameservers (not

It now also says: oneirofono .gr: The nameservers of the domain returned an error. Please note that DNS changes can take up to 24 hours to take effect.

I am trying to renew my SSL certificate but it shows me the above message.

I’m using this software:

Let’s encrypt free SSL

I also do not remember where i find my key and where to paste it. You changed the looks of the vistapanel and i’m confused.

Hello there,

That’s because you are using the ns1 - nameservers, using those nameservers causes this issue, please make sure to just use ns1 -

Just what I mentioned before, you must change your nameservers to ns1 -

I’m not sure but the only things that have changed are that some options are gone.
This is what vPanel looked like before when I started using this hosting around Dec 2017:

I miss those days when the Sitepro site builder was still a thing.


It now says again: Your certificate has been requested and will be created shortly!

i found where i copy paste…

With a refresh it says the same again…

I have to change nameservers? Till now it worked fine…

my cname records are valid…

If it has worked fine for you and you succesfully got an SSL certificate then no need to change the nameservers.

Well it used to work now i want to renew the ssl it expires on June 11th.
I want to renew it and then this is the problem it happened.

What shall i do now…

Is there any moderator to help ?

I’m confused, then what do you meant about this then?

So what problem are you facing exactly??

1 Like

My site works. My ssl works but when i am trying to renew the ssl then i have this message:
SSL certificate error: Your domain’s nameservers didn’t respond correctly.

That’s why I told you, try to change your nameservers to ns1 and instead of using ns1 -

The previous time i had a similar problem infinityfree ficed the issues.
I want to know if this time it’s the same.

I also don’t know how to change name servers. I just go to my domain host and simply change the word with or do i have to make some changes on my infinityfree account too ?

You just need to change your nameservers just like how you set it to ns1 -

Put the nameservers in their proper place.

Yes, we fixed the DNS issues. On the nameservers, not on the ones. Which is why the error message clearly says: you need to use and, and not any nameservers. Which your domain name isn’t right now (it’s pointing to and

So please go to the nameservers settings and remove everything. Then, add only and and save. If you still see, you’ve not set the right nameservers.


Are you going to fix the DNS settings for or i only have to use ?

I have to use new nameservers and set them again following the whole process again ?
I will do this on saturday because on Friday i stream radio…

Again, you have to use namesevers, not I know the SSL verification issues are resolved on And, to my knowledge, there are no plans to also do this for So if you want to be able to get your SSL certificate easily (without having to play the “will all Let’s Encrypt’s challenges succeed” lottery), you should remove ALL nameservers from your domain and only use namesevers.

What “whole process” do you mean? You just change the nameservers at your domain registrar, wait for 24 hours and click the Request SSL Certificate button in the client area. That’s it. You don’t need to make any changes to your website or your hosting account to setup your domain name or the CNAME records again. The and nameservers serve the same DNS records, as they have always done. The only difference now is that the nameservers cause weird issues with Let’s Encrypt while the nameservers don’t.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.