SSL Certificate randomly invalid


I used a SSL certificate for more than 4 months, I renewed it, it worked for about a week, and without any changes, it now looks valid one day, invalid the next day. I never had that issue with the previous one.

Is Infinity having any issues about SSL certificates ? Are they randomly changing the CSR or private key (I don’t think that would cause the issue anyway, since the certificate has been issued properly) ? If not, can someone help me fix it ?


Yeah InfinityFree having some SSL Certificates problems, I’m not sure, but I’ve seen few threads about this before. Maybe something gone wrong after some stuff they’ve done, recheck your certificate installation and post your website link.

By rechecking my certificate installation, you mean entering the same data, or validating a new certificate ?
Because last week I did recreate a new certificate, and the problem remains. The servers must be sending wrong or broken data about certificates.
I don’t think the issue can be fixed on our side, but rather on Infinity servers config.

Does your certicifate content goes all asterisk (*)?

I did experience same thing even though neither my certificate goes invalid (expired) nor I did any changes to private key.

Good thing mine’s lets encrypt, so I could just create a new one.

The certificate going all asterisk is, to my understanding, the default one sent from Infinity servers when you request a HTTPS page but you don’t have your own certificate. It is valid 3 years.
Mine is also Lets Encrypt, so of course I tried to create a new one before posting here. But same issue, randomly works :wink:

When you install SSL certificate on your free hosting account, did you allow it to get activated fully for 24-48 hours?

It happened to me before and just recently. I almost crashed my site for the reason of delay but I guess this just how it works on free hosting…

It’s delayed, of course, but it works and then randomly stops, and then works again…

Maybe this is due to the ongoing maintenance. Let’s just hope for the best. :slight_smile:

Yes indeed. My post was only to see whether the admins had noticed so they could investigate.

I don’t think admin has control over this issue. Hope this will be taken care of by the servers supplier in no time since the access of emails is important to any user’s business transactions