SSL certificate problem

Hi everyone,

I’ve got a “SSL certificate problem: unable to get local issuer certificate” with my domain (
I’m learning how to use InfinityFree and WordPress, so I don’t know/understand a lot of things.
I want to create a Woo Commerce using Printful, but I can’t connect those due to this error.

I’ve searched on the internet, and I didn’t see any solution.
I’m using “Really Simple SSL” and Free SSL Certificates by InfinityFree, provided by GoGetSSL.

I personally tried to put my custom domain on CloudFlare, but I don’t know how to transfer my SSL and how to point to (InfinityFree’s base domain).

Thank you in advance to those who will take the time to help me

Sorry I’m Italian, my English is not perfect, so I hope you understand the steps, I’ll try to be as clear as possible.

Then the first thing to do is the following, take your top level domain and connect it to infinityfree then wait for the domain to connect correctly, then go to CloudFlare enter your domain choose the free plan then you will be shown the DNS records ( if you also need the email also choose the MX record and add it if you need it, but now leave this alone, let’s go back to what interests you) then just continue on the button that is shown to you and finally you get the names servers that are of interest to you, that is NS1 and NS2, then go to the site where you purchased the domain and replace the name servers from those you previously should have connected to Infinityfree to those that are shown to you on CloudFlare

So in short, you have to copy NS1 and NS2 from CloudFlare and insert them on the platform / site you purchased the domain, then replace the name servers on the site with those of CloudFlare and then confirm by changing the servers and aspects that propagate, it can put immediately for example 15 minutes or from 24/48 hours usually immediately!

then go on to CloudFlare once done and go to SSL / TLS options then choose the “Flexible” option then on the Always Use HTTPS item put on On and then click done then go back to the let’s say main page of CloudFlare then on the item at the top " Overview “scroll down slightly and click” Re-check now "then reload the page and when the domain is switched to CloudFlare there will be a confirmation that will tell you that the switch has taken place

then go back to SSL returns from “flexible to the full item” then within the SSL item there is a submenu so you are now in SSL => Overview you should move to the submenu item on the “origin server” item and click on create certificate and then a window comes out and then you go ahead and you come out with the certificate of origin and the key, then you go back to the infinityfree control panel and go to the SSL => configure item and paste the two certificates and then load them both and you have done let’s say this first step then there is a second part to do, I suggest you use the really simple plugin that you may already know and then you should make some changes, but I think you know how to do it, in case you just ask and answer you I can, I hope I’ve been of help.

1 Like

The website is already secured
just add https:// to the front of the domain
like this

if you want to redirect to domain to https if someone goes to the non secured website
go to your .htaccess in the htdocs and add this

RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]

NEVER go to the .htaccess that is out of the htdocs directory and never put that in


CloudFlare does not support this.
Is better to use Let’s Encrypt SSL(easier to renew SSL) and CF for custom domain.


you cannot get ssl certificates from 3rd party websites like because of the security system, if you want to get an ssl certificate you can do that in the client area of your account.

1 Like

ive also detected that your website isnt redirecting from http to https, use this code to fix this:
RewriteEngine On
RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$$1 [R,L]


Connecting my domains to CloudFlare isn’t the problem, the problem is how can I add the InfinityFree nameservers in CloudFlare? I see an option in the DNS tab, but I need to pay.

Really simple SSL has added someting similar, the https redirection should work:

# BEGIN rlrssslReallySimpleSSL rsssl_version[4.0.5]
<IfModule mod_rewrite.c>
RewriteEngine on
RewriteCond %{HTTP:X-Forwarded-Proto} !https
RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [R=301,L]
# END rlrssslReallySimpleSS

php_value display_errors Off
php_value mbstring.http_input auto
php_value date.timezone Europe/Paris
# BEGIN WordPress
# Les directives (lignes) entre « BEGIN WordPress » et « END WordPress » sont générées
# dynamiquement, et doivent être modifiées uniquement via les filtres WordPress.
# Toute modification des directives situées entre ces marqueurs sera surchargée.
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
# END WordPress

In the .htaccess file?
I’ve got something similar, look at my answer above

1 Like

You dun do that.
You only add A/CNAME record of the main domain under the DNS tab of CF


if you bought the custom domain, i think it can connect without problem, the problem is that CloudFlare doesn’t accept infinityfree subdomains, so only subdomains can’t connect to CloudFlare

Yeah. CF doesn’t allow subdomains only accepts root domains such as, etc

So, I’ve setup CloudFlare, but my website redirect to
If you want to see:

When and where exactly do you see this error?

This issue can happen if your website tries to connect back to itself. That doesn’t work with our SSL certificates. However, this is generally only something Health Check plugins complain about, I’ve yet to see any cases where this is actually an issue.

Cloudflare does SSL for you automatically. No need to transfer an existing certificate there. I think they don’t even let you do that on their free plan.

This is because the domain name is not assigned to any hosting account. You are sending traffic for your domain name to our server, but our server has no clue whose domain that is and which website it should show on it.

You’ll need to add it to your hosting account first:

This does mean you’ll need to change your domain’s nameservers back to us to do it. But as soon as you’ve added the domain to your hosting account, you can change it back to Cloudflare’s nameservers.


It work, thanks!!!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.