SSL Certificate not working

Username (e.g. epiz_XXX) or Website URL

(please specify the website or account you are asking about)

Error Message

“Please set up the CNAME records at your domain’s DNS provider.” But I already setup the CNAME record in my DNS server on NameSilo more than 24 hours ago.

(please share the FULL error message you see)

Other Information

I am trying to configure a free SSL certificate on infinityfree. It asked me to create a CNAME record with my DNS provider. I did that on more than 24 hours ago. However, infinityfree still asks me setup the CNAME record. It’s as if infinityfree is not reading the CNAME record.

(other information and details relevant to your question)

dig ns shows namesilo’s name servers. Do you add your domain previously? Or it could be an effect of current outage.
Also don’t mix your domain’s A record with any other address than InfinityFree ones.

If you are using InfinityFree, you need to use InfinityFree nameservers, or an A record. The place where you nameservers point to is where you add the records, but it will only work if you domain is still connected to your account (Either by NS or A records).

Can you please screenshot the setting(s) that are currently pointing your domain to InfinityFree?

I initially set my nameserver to ns*, but changed the nameservers back to namesilo’s default name servers after a couple of days. The domain name is still pointing to my website hosted on infinityfree.

Here’s the screenshot with the A records.

I believe the values should be and

1 Like

Um, no. They should be:

NAME: IP address from

CONTENT: “www”
NAME: IP address from

What are the other A records for? The hostnames are the same, so I think that’s going to cause some errors. I would remove all A records except for the IF ones

Also, can you screenshot the DNS CNAME records for the SSL certificate?

1 Like

I set the A records to the IP address from The other A records are included with Namesilo - I don’t know their purpose but I don’t think they are interfering with the SSL cert.

I included the screenshot of the CNAME for the SSL cert, but blacked out the code.

As I read in infinitifree’s documentation, the nameserver can be set back to the original nameserver after custom domain verification if I wish to manage DNS with Namesilo.

That is correct.

Admin will take a look at this when he comes online, it all looks right to me.

When I do a DNS lookup by hand, I don’t get any results for the CNAME record. And here is an example of that query using a web based DNS lookup tool:

Looking at the screenshot of the DNS settings at NameSilo, it looks like you provided the right configuration, but somehow this isn’t being applied on NameSilo’s nameservers.

Perhaps you could try asking NameSilo about this? Because the problem seems to be in the nameservers, not our DNS check.


Upon advice from Namesilo support, I deleted the CNAME record and recreated it. I will check after 48 hours of propagation if the issue is resolved or not.

Bro search for CNAME Records in infinityfree cpanel try adding there it works

@Subrahmanya : I don’t use infinityfree as my nameserver. I use namesilo instead. So your suggestion does not work for my case.

1 Like

I just checked again and it seems OK now. So you can probably get the certificate now.

It takes up to 48-72 hours for DNS propagation, but mostly due to stupid DNS caching. Both our CNAME validator and the certificate providers are configured to pick up DNS changes within minutes.

I verified the CNAME record. Moved on to the next step of installing the certificate but met with an issue.

  1. I first generated key/CSR from Control Panel → SSL/TLS → Configure
  2. Then I realized that I was not supposed to do this. Instead I should copy the private key and Certificate from the “Free SSL Certificates” page and paste it in the SSL/TLS → Configure page. So I tried to “Delete Certificate” in SSL/TLS → Configure page, but it’s not deleting the certificate. There is an error that shows at the top in a yellow bar, but the error disappears in a millisecond that no one can possibly read it.

@Admin , Can you please help with deleting the certificate? Or, provide a solution?

I was able to workaround the issue of not being able to delete the certificate. I pasted my private key for the Free SLL Certificate on top of the existing private key and clicked “Upload Key”, which deleted the existing cert and uploaded the free cert key. Issue resolved.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.