SSL certificate not being issued

Username (e.g. epiz_XXX) or Website URL


Error Message

No error message, see other information

Other Information

When renewing my existing SSL certificate, I click on the Verify button for my domain it takes me to the Verify your Domain page. On that page the current destination has a red Not Ready button with instructions to set up the CNAME records for my domain. I haven’t deleted/changed the CNAME records and they both are there under the CNAME records.

I have done the free SSL many times with out problems. Can someone please take a look and see if I’m missing something, or has anything changed that I’m unaware of? Thank you in advance for your replies :slightly_smiling_face:

1 Like

Hi and WB

Maybe is this


I have deleted all (both) CNAME records, I had two CNAME records with each one having a destination, I’ve added the new DNS and it’s corresponding destination. Does the [] only have one CNAME with one destination? I have deleted the SSL certificate, the CNAMe records are changed, I’m waiting for the DNS records to change, when I verify the domain it still shows the old _acme-challenge domain.

Thank you for your help, so far this has been an easy one to answer, talk to you later :wave:

P.S. I will mark this topic solved when I can get the SSL certificate/key installed.


I have waited approx 19 hours after deleting and replacing the records with the record, the Record Name hasn’t changed on the Verify Domain page, still shows _acme-challenge. There is only one destination record now, the Verify Domain shows there is no current destination record since it was deleted with the CNAME records. I don’t know what should be in the current destination field, see attached Verify Domain screen snip for exactly what is showing:

Can you screenshot the record in the control panel? I can’t seem to bring anything up on my end.


Currently leading nowhere (no destination match) Dig web interface - online dns lookup tool

Best to wait for the admin,
if he doesn’t show up today then probably tomorrow morning.
You have a few more days (current cert expires on may 11.)


@Greenreader9 here’s the record from Cname records, @Oxy that’s exactly what I thought, since I deleted the CNAME records the current destination was deleted too, I was only able to locate the destination.

The record source is incorrect. It should be _acme-challenge


@wackyblackie That appears to have solved the issue, thank you very much :grin: I now have both destination and current destination on the Verify you Domain screen. I will install the SSL and report back…


Success!! SSL certificate and key have been installed, records have been fixed, thanks to all who viewed/replied, @Oxy, @Greenreader9, and @wackyblackie :100: :muscle:


How much actually means a screenshot and more eyes !

Now you can dedicate yourself to forcing HTTPS
so when someone enters your domain it automatically takes them to the HTTPS variant

Somewhere around the middle

and you could use Cloudflare also


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.