SSL Certificate Issues

Hello there,

I’m having an issue with the free certificate options provided by (Free SSL Certificate feature). I follow the instructions in the tutorial video on how to set up the SSL Certificates for my domains, and I had no issues at all setting it up for one of my websites. The other two domains it’s not setting up for some reason which I can’t seem to figure out. :unamused:

I click create new “SSL Certificate”, Enter the domain name and click continue. Choose “Let’s Encrypt” as the recommended provider. It says Ready. And I request the Certificate, and it said: “SSL certificate error: The provider returned an unknown error. Please try again later.” On another domain it says “Draft” and never clears. It is eating at me because with one domain it worked perfectly fine, and I completed the entire setup creating the .htaccess with the right redirect code.

Why is it not letting me set up the SSL Certificates on my other domains to make them secure?

What am I doing wrong?

It worked for:

Not working for:

InfinityFree User

Free hosting is currently experiencing some dns issues.
As a result, you may face some difficulties obtaining SSL certs.
Patience please…


I’m not having issues with the DNS servers. I’m having issues with the SSL Certificates on 2 of my domains. The websites are loading just fine.


I see this



You did not use IF nameserver ( and OR did not setup the correct
CNAME record at your domain registrar

Should be fine. Did you follow the correct procedure to get free SSL?


I checked the SSL orders you have on your account.

There is no order for There is an order for, but that one is still draft.

The one for failed because Let’s Encrypt could not find the validation record. That could be because of the DNS issues, but it might be something else.

I can see that you removed the validation CNAME record from the domain. That record must remain present while until the certificate order is completed, and it’s recommended to leave the CNAME record there. The same CNAME record is needed again if you want to renew the certificate after three months, so leaving the CNAME there saves you some time later on.

In any case, my recommendation is just to try again. Random issues can happen, especially with the current DNS issues, and if you try again, it usually just works.



I followed the steps, and maybe I was rushing and was doing something wrong the first time yet I don’t understand what. Patience might’ve had everything to do with it. I got the certificate working now & the in draft status. Sometimes just got to step away from the PC for a while because frustration doesn’t make anything easier. Thanks for the support.

To InfinityFree & Beyond!


Thanks for your help & support, I successfully installed SSL Certificates on all three of the domains thanks to Support System.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.