SSL Certificate is not "refreshing"

Username ( [epiz_30172968]) - Website URL:

Error Message:

I requested a new certificate from ZeroSSL like I usually do.
Usually it takes maximum 10 minutes to get it working but this time it took too much to get it issues like two hours. I thougth it is not a big deal even it is stated it takes up to 10 minutes to be issued.
When it was issued I installed the certificate and since yesterday it has not been activated.

I am getting this error : NET::ERR_CERT_DATE_INVALID when I open my website.

My problem is, that the SSL-Certificate is not updating. My certificate has been expired yesterday, and i have issued a new one this morning. The problem with that is, that the old Provider for the DNS was ZeroSSL and my new one is GoGetSSL.

I’ve set up my CNAME-Records and everything i’ve needed to get the Private Key and the Certificate.
The Private Key and Certificate are now being placed in my VPanel for two hours. But when i’m looking at my page it still says the certificate from ZeroSSL is installed.

As of recently we are sometimes seeing issues with updating SSL certificates. Requesting the SSL certificate works (with all vendors) and you can install them into the control panel, but the server keeps using the old SSL certificate.

I’ve asked iFastNet to take another look at this and activate your certificate for you.


2 posts were merged into an existing topic: Dns_probe_finished_nxdomain

Both are my domains and will be redirected only and no confusion this ssl is changing and it is redirecting to other

@KangJL just after msg to Admin he refreshed and my old name record has been removed now. Let’s try to install new one.

But Thanks @KangJL few domains were worked after your suggestion on removing and adding domains Thanks

Continuing the discussion from SSL Certificate is not "refreshing":

@Admin DNS propagation/caching process taking too slow. Still not even showing

This issue was fixed yesterday. If I check the site now, I see a ZeroSSL certificate that was issued on the 22nd of December.

Please check the page in Incognito Mode as well, as SSL certificates may be cached in regular browsing mode (which clearing browser cache does NOT fix).

I’m not sure what issue you are having now and why you’re talking about DNS cache, because this wasn’t a DNS issue to begin with.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.