SSL Certificate for my subdomains?

my domain is

Error Message

with blog(dot)braianpita(dot)com it works fine on PC but…
I get the error DNS_PROBE_FINISHED_NXDOMAIN on my phone.

on PC blog(dot)braianpita(dot)com works fine but when I try to use:
https:// blog(dot)braianpita(dot)com I get the error:

Other Information

I bought my domain on godaddy, but decided to use the free hosting service because its a personal website which will have very low traffic. My main page works fine and I added the free certificate which works correctly; however, I now tried to create the subdomain blog(dot)braianpita(dot)com on the subdomain section of CPANEL but it appears to be giving me some issues mentioned above… Do I need to set up a separate certificate for this subdomain? If so I do not find the way to do it, and it not I do not understand whats the problem.

You need to manually create a subdomain first for your addon or custom domain by navigating to Subdomains from control panel.

I don’t know if the ssl free certificate from infinityfree client area will work for subdomains. I have used cloudflare for a free ssl even for subdomains (


I already have set up my subdomain in cloudflare and blog subdomain works fine. My problem is with the https. I had set up my domain with free ssl from infinity but I also set up cloudflare now since I was researching. Do I have to manually take out the previous SSL??

Did you already change your nameservers to Cloudflare nameservers? Because you need to manually change your nameservers to cloudflare NS so that your domain will get verified for cloudflare ssl and dns management.

It depends on you if you want to remove the previous SSL, but I highly recommend you not to remove it so that you can use the Full mode from Cloudflare SSL/TLS instead of only flexible mode. Because full mode will only work if you do have an origin certificate from your server or infinityfree server.


Your site is working fine for me on mobile.

Well, I fixed my domain and so far it is working but the subdomain only works with the http version, the https says ERR_SSL_PROTOCOL_ERROR, which I understand is because it needs to be certified, which it should be since I completely transfered to cloudflare and my main domain appears to be certified.

I have dns through the infinity free dns configuration, should that matter? I tried changing it to cloudflare before but I had to start from scratch to do that since I am unable to find my cloudflare nameservers now. on the DNS section it says " Your DNS zone file is hosted by Byethost , a Cloudflare partner. Manage your DNS records at their website.", and if possible I prefer not messing with it a lot since it gave me trouble when I tried deleting my site from cloudflare and instaling it from scratch to get their nameservers. Or is there a place where I can find my nameservers and change it to cloudflare?

This happened if you setup the cloudflare using the alter cloudflare or from Infinityfree cpanel. I suggest you to setup the cloudflare for your domain manually by changing the nameservers into cloudflare nameservers. This will allow you to edit your dns records (useful for google domain property)

Actually, cloudflare will automatically give you an two cloudflare nameservers for your domain or cloudflare account, just after you manually create an account on cloudflare or after adding your domain.

You will need to change your nameservers to cloudflare nameservers or by the given cloudflare nameservers after you’ve verified the domain from infinityfree.

From ns1, ns2 into cloudflare nameservers.

This will also only happen if your sub domain doesn’t have an ssl. So yeah, cloudflare can help you with that.

How to add an SSL for your subdomains

  1. First, you need to create an subdomain in your cpanel from infinityfree.
  2. After you’ve change your nameservers to cloudflare or after you’ve verified your domain on cloudflare. You will need to create an A record in the DNS management that you can see on cloudflare dashboard. It must be proxied.

Name = blog(or the subdomain name)

IPv4 Address/Destination = (Your domain ip address, you can find it on your account client area)

That’s all!

1 Like

Hi, I changed my nameservers to cloudflare and it appears it already had the A configurations. This is what it has:

A - blog - myIP - Auto - Proxied
A - - myIP - Auto - Proxied
A - ftp - myIP - Auto - Proxied
A - mx - myIP - Auto - Proxied
A - www - myIP - Auto - Proxied
CNAME - * - - Auto - Proxied

I dont know if that is all correct. So far everything is the same, I will check in a few hours to see if anything changes, but still no certificate.

After you’ve change your nameservers to cloudflare or after you’ve verified your domain on cloudflare. You will need to create an A record in the DNS management that you can see on cloudflare dashboard. It must be proxied.

Ok, after a few minutes it is now working! I spent a whole day trying to fix this and you finally gave me the answer I needed! Thank you a lot!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.