SSL Certificate and private key installation problem


The private key you are trying to upload is not valid.

The certificate uploaded is NOT for the domain name ( was seen) .

These are the errors shown when I am trying to upload a private key and ssl certificate respectively, I got the key and certificate from let’s encrypt

Make sure you follow the instruction

Else try using a different browser

1 Like

@KangJL I have followed each step and I got my ssl through client area still it shows the same problem. Maybe @Admin can help ?

You have to wait then

1 Like

you sure that you pasted the key and certificate in the rt place

@thenamaskar Yes I did , I am starting to suspect there is problem with my account or hosting , I recently posted a problem stating about the problem with mysql in my account

Create a new hosting account or create a new SSL certificate from a different provider.

@jaikrishna.t I have already tried a different provider like zero host , I will try making a fresh account

1 Like

Genarate A New SSL by infinityfree ( Lets Encryped Sll ) Or Use Cloudflare ( I am Recomonded Fro You )

@chamith12 But I saw in the forums that cloudfare ssl is not supported and I have tried let’s encrypt too

Your domain should work on CloudFlare

1 Like

@KangJL is not my site I just have a subdomain from it

That’s what @KangJL meant.


Okay I am going to check

I just tried to upload the private key from your Let’s Encrypt cert to the client area. That worked without any issues.

As the installation instructions say, please make sure to upload the ENTIRE content of the box in the client area. That includes the lines with the dashes, those are actually part of the key text.

1 Like

I actually did I but it showed me the error I will try again

I checked it thanks to @Admin private key was all set but I swear when I tried to upload the certificate it showed me error I mentioned in the question. And BTW I am using my phone for copying the certificate ( starting from ----Begin certificate---- to -----end certificate----- )can that cause the problem

1 Like

No man it is not working for my site

The problem is solved I think there was some kind of hidden ASCII character when I copied the certificate and key using my mobile now I am using my PC and everything went smoothly


I am recomoned fro you Cloudflare Free SSl ( Lifetime)

search on google cloudflare free ssl

but it is work only fro custom domain