{Solution} FTP Could not Connect to Server

Error Logs:
Status: Resolving address of ftpupload.net
Status: Connecting to 185.27.134.11:21…
Status: Connection established, waiting for welcome message…
Response: 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
Response: 220-You are user number 694 of 2900 allowed.
Response: 220-Local time is now 13:52. Server port: 21.
Response: 220-This is a private system - No anonymous login
Response: 220 You will be disconnected after 60 seconds of inactivity.
Command: AUTH TLS
Response: 421 Timeout - try typing a little faster next time
Command: AUTH SSL
Error: Could not connect to server
Status: Waiting to retry…
Status: Resolving address of ftpupload.net
Status: Connecting to 185.27.134.11:21…
Status: Connection established, waiting for welcome message…
Response: 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
Response: 220-You are user number 1154 of 2900 allowed.
Response: 220-Local time is now 13:54. Server port: 21.
Response: 220-This is a private system - No anonymous login
Response: 220 You will be disconnected after 60 seconds of inactivity.
Command: AUTH TLS
Error: Could not connect to server

Solution

I’m using Filezilla:

  1. Go to File (top left Corner in filezilla)
  2. Open Site Manager
  3. Do these settings:

Be sure to Select connection type “insecure”

Hope that this Helps…
Comment Below for any problems…

This solution is being discussed in another topic now, so I’d like to copy some messages here:

@DhananjayS said:

@Admin said:
It’s good enough as a workaround, but not as a solution. Solving the issue would mean everyone would be able to connect to the FTP server securely. Since you said you “solved” the issue, I had hoped that you would say “software X version Y on device Z has this issue, and if you configure A and B, then you can setup a TLS connection”. So I was slightly disappointed.

Yes I agree this is temp. solution and FTP connection not secure, but the host server address is of http://ftpupload.net not https://ftpupload.net that is why we have we have to disable TLS.

One more thing this issue is causing on Fillzilla as I mentioned, but the Version of Filezilla don’t matter’s because I’ve tried Some Older versions as well as newer versions but the issue persists, so I though their might be and issue on server side not in software and I thought not to mention any specific version of software.

The server address isn’t http://ftpupload.net. That URL is a HTTP URL (hence the http:// at the start). But the server is not doing HTTP, it’s doing FTP. You may be able to explicitly give the protocol by using ftp://ftpupload.net or ftps://ftpupload.net.

But the default behavior of FileZilla (which works fine for >99% of the people) is to use “Explicit TLS”. That means the connection is setup as insecure first, and is escalated to TLS after the connection is set up. This is done with the AUTH TLS command, which you can see is the last command being sent from your connection log.

I just dug through some bug reports from FileZilla about this issue, and it seems the issue is either caused by:

  • The target server not being configured correctly for FTP over TLS.
  • A firewall blocking the connection.

I don’t think option 1 applies, because most people (including myself) can connect with TLS effortlessly. So the most obvious answer would be that it’s caused by a firewall on your end (either on your computer, your own network or your ISP). Which would explain why some people cannot connect but most people can.

Do you happen to have a VPN service by any chance? If so, you could test if you can connect over the VPN.

Dear @Admin,

Yes you are correct your Second point:

A firewall blocking the connection.

Is correct, I’ve tried using VPN I was able to connect, but one pop-up appeared:

As Admin said: either on your computer, your own network or your ISP is causing the issue due to this unknown certificate.

One more thing I tried connecting both, ftp://ftpupload.net as well as ftps://ftpupload.net with my original ISP, means without VPN.
Even the problem persists…

Any comments on this will be helpful to resolve this issue completely.

That popup is completely normal, it just lets you double check the SSL certificate. And since there is no red text, it means there are no issues and everything is safe. So you can simply click OK and proceed with the connection. Why FileZilla doesn’t accept the valid certificate automatically is beyond me.

To me, the answer seems quite clear: your router or ISP is blocking the secure FTP connection. Which leaves three “solutions”:

  • Disable secure FTP and let your ISP spy on you.
  • Ask your ISP to remove the block.
  • Use a VPN to connect securely over FTP.