Softaculous : InvoicePlane not installing properly

I have so far tried multiple times, and it is not working correctly. When i tried to install to a folder, the url goes to a IP address which I believe is a local IP address. How to get it to install correctly ? and ensure it points to a real IP address on infinityfree ?

Thank you

I’m sorry, but how is it not installing properly? Does Softaculous show an error? Or does Softaculous complete without errors and does the site not work?

Also, could you include a URL on the site so we can actually see what the issue is rather than have to guess?

Softaculous does not show an error. It shows it finished installing 100%. But the url it gives in this case it gave for accessing invoiceplane after the installation is complete, goes to when I try to go to that url. By default, thats the directory it installs in.

I also have taken screenshots during installation, but the attach image file on this interafce is not opening the dialog box to attach file.

Following are the messages and url I get, after installation
Congratulations, the software was installed successfully

InvoicePlane has been successfully installed at :
Administrative URL :

when I try to go to - it goes to
Content displayedNot Found

The requested URL /invoice/index.php/welcome was not found on this server.

Apache/2.4.18 (Ubuntu) Server at Port 80

If I try to go to

it again goes to with the same content displayed.

So although the message I get is successful instalation the url provided, I can not go to , to access the software. Can you please help.

Please let me know if additional information is needed.


I am using a Ubuntu linux Desktop 16.04 LTS and I looked at what version of web server is my machine running and coincidentally it matches. Not sure why is redirecting to the local server

sunil@sunil-OptiPlex-GX620:~$ /usr/sbin/apache2 -v
Server version: Apache/2.4.18 (Ubuntu)
Server built: 2017-09-18T15:09:02

I also tried stopping the web server running on my machine to see if it would do any different, but when I stop the local web server it just fails to load the page instead of 404 since it can not access the web server.

So I believe the first issue is why the normal url is redirecting to the local server.

Hope this info helps in troubleshooting.


I also checked from another machine to isolate the local web server .

There, the message is refused to connect. When I looked under General php info on cpanel I see that is the local address under Apache Environment

Apache Environment

Also I checked the web server address running locally on my machine which is and is different from where the url is trying to go to. So it does not appear that it is trying to go to my local server, but some setting on Infinity Free side is directing it to, and that is not working.

Please help.


I get the same redirect, but I’m not running a webserver on my machine so I just see a Connection Refused page., just like all other IP addresses starting with 127, is an IP address of the local machine. On your computer, it points to your own computer. On the hosting server, it points to the hosting server.

We run a bit of an unconventional server stack, but most scripts never notice that. InvoicePlane on the other hand seems to look at a the SERVER_ADDR parameter and believes it would be a good idea to redirect visitors to that IP address.

I took a look at the script configuration, but I didn’t see anything that could easily explain this issue. You could try to do a manual installation to circumvent any possible issues with Softaculous, but I have no idea what could be causing this either.


I got around the issue I had before by modifying one of php setting files within the application. But not completely out of the woods yet. Now I am at the step where it needs to connects to database. I have made sure that all the below names are valid but I get


The hostname for your database.
The port your hostname is listening on. Default is 3306.
Username associated with the database.
Password associated with the database.
The name of the database you created for InvoicePlane.

Can you please help in identifying why it would not connect to the database. I also checked with host as when I connect to it from phpmyadmin thats the host it shows, but that also fails to connect.

Thank you