Sites loads too slow

Website url: (free account)

The problem:

I mentioned in the last few days, that when I open the site for the first time from 2-3 hours, It loads very slow. I tried to deactivate some plugins like firewall, security, caching plugins and etc., but result is the same - it works when I open it frequently.

I have one more site here and right now I noticed the same thing. I’m relatively new here and my site isn’t advertised yet. Still under construction.

Is it a global problem with the hosting or? Has it happened to you?

Thank you in advanced!

Its fine i just checked it and its ok :slight_smile:
the website is working great

1 Like

Now - yes. Two hours ago the problem was there.

WordPress’ background process system usually means that the first request after a few hours of inactivity will take a bit longer because it still needs to run some pending tasks. This is just how WordPress works, there isn’t much you can do about this.

It’s true that deactivating plugins can help. But if there is one plugin that is quite heavy on the background processes but is also crucial to your site, there isn’t much you can do about it.

This can happen to any WordPress site on any hosting.


Yea, thank you so much for your answer. I mean that. But I didn’t know that there was this thin moment like that. :smirk:

Before ticking your answer as a solution, are there any opportunities to reduce loading time for first time visits? Any optimizations are possible or it is a waste of time?

Thank you again!

You could try to hack around it by setting up a cron job every hour which will take care of some of the background processes.

But without rigorous profiling, it’s hard to tell what exactly is causing this on your site.


I tried. Last night I installed one plugin which allows additional cron jobs setup and set once hourly 2 items in it (wp_version_check and wp_https_detection). No result. In the morning I installed a different plugin with option to create a custom cron job, but I don’t think I was able to set it up.

The last attemp: I have a database optimizer plugin, which allows to set schedule optimizations. Changed it from once weekly to once hourly, but again without result - right now, when I visit the site (for the first time from 2-3 hours), it takes ~1-2 minutes to start loading its contents. :neutral_face:

I meant a cron job on a hosting account which loads WordPress every hour so WordPress can run it’s background tasks without a visitor being present.

Decreasing the load time of the WordPress cron runner cannot be fixed by adding more stuff to the WordPress cron runner.

I don’t see any reason to believe that this is a database issue. And again, you won’t fix the issue of slow WordPress background jobs by adding more background jobs. Which is exactly what you’re doing by adding these optimization plugins.

Remember, many issues with sites are not fixed by adding more plugins.


Thank you again. The site shows a better result with fewer plugins.

Do you know what command needs to be executed in cron jobs to maintain the website alive?

Just tell the cron job in the control panel to load your homepage every hour or so. Also, remove the cron jobs from Wordpress, unless you need them.


It seems to work with a cron job in host panel and reference to a some page of the site.

Admin, greenreader9, thank you for helping me to fix the problem. :beers:


you can try a caching plugin

1 Like

The site is slow again, with a cron jobs in it…

WebPageTest Check: WebPageTest Test - Running web page performance and optimization tests...

Once first view completed for 5-6 secs, second time - 20+ secs. I don’t know what’s wrong. :neutral_face:

‘ - /’ loading takes 17 seconds :thinking:

Can you show them please?

Yes, ofcourse.

First I tried to set them on 1 hour, but now on 15 and 30 mins.

Now i’m trying to install a CDN and compare results.

Try setting it to just the main page of the site (

No. Can’t do this.

The command entered does not appear valid.

An example of a valid path would be .fit/myscripttocron.php 2

Today my site get blocked for 24 hours.

Hm, maybe Admin will have a better anwser

If you want to poke the home page of your site, just enter / in the URL field.

I tried but didn’t work: The command entered does not appear valid.