Sitecake editor admin not working?

Hi, I installed sitecake from softaculous onto to test it out but the admin doesnt allow me to login and instead just shows the website with broken images

Is there some configuration I need to edit ?


This is the admin page

Working for me, clear your cache.

did you get into the admin ? or just load the main site ?

here try the admin login

All external files return a 404 error. Check yourself in the Dev console.


hmmm it looks like the softalucous installer installed sitecake where I specified to /sitecake but is trying to load images from /img instead of /sitecake/img

something is wrong with the installer

is that correct ?

i’ll install to root and see what happens

installed it to root but same issue :frowning: (ok) (admin not working)

gonna write some php to test the get problem, possibly needs the full server directory structure ?


i dont have enough knowledge to fix it :frowning:

Then, I think its better to actually ask SiteCake Community about it. Sure they will help you more:

SiteCake Forum


well I asked here because I used infinityfree softaculous installer from cpanel

i’ll wait to see what IF’s admin says

somehow this just got marked solved ?

this isnt solved

I think I know what’s going on.

I think the issue is caused by using relative URLs in your HTML code. For example, looking at the styles and scripts:

<link rel="stylesheet" href="css/reset.css" />
<link rel="stylesheet" href="css/style.css" />
<link rel="stylesheet" href="css/sitecake.css" />
<link rel="stylesheet" href="css/pt-serif/type.css" />
<script type="text/javascript" src="js/modernizr-2.5.3.min.js"></script>
<script type="text/javascript" src="js/jquery-1.7.2.min.js"></script>

All the hrefs start with a directory name, not a slash. That means the browser will try to load the URLs relative to the current directory, not relative to the base of your domain.

At your homepage,, this works fine, because the domain base is the same as the current directory.

But when opening the URL, the browser will think /sitecake.php/ is the directory, because it ends with a slash. So it will load the files from,, etc.

To fix this, you can replace all the href="css/, href="js/ and href="img/ in your site with href="/css/, href="/js/ and href="/img/ respectively. That should fix the layout for your SiteCake preview.


thanks for the info admin, i’ll ftp the whole thing to my local hdd, search and replace and then push it back and see what happens

this site is the default template installed by sitecake on softalucous so i guess its a bit broken then :frowning:

1 Like

well I fixed the 4 html files as suggested and this fixed the image issues but still the admin login / editor isnt working and just shows the regular page

Clear cache…

again with the clear the cache ??? lol

here try it and clear your cache, good luck see if you get the admin login page

nice, I love 404 errors :pleading_face:

if youre getting a 404 then there really is something weird going on as it is loading for me even after clearing the cache except i still dont get the admin login