Site Goes to Maintenance Mode


This not good.
I am unable to update my wordpress plugins. I really don’t know the issue.
When I have clicked on the plugin update button, then it will be showing error which is “Briefly unavailable for scheduled maintenance. Check back in a minute.” And after that it stuck for one to two minutes
I don’t know this infinity server issue or wordpress issue.

To remove the maintenance mode, remove the .maintenance file on the htdocs on where you installed WordPress.
To upgrade plugins you may have to upload them via FTP. Just download them from WordPress Plugins |, searching for the name of the plugin and downloading it, extract the zip file and upload the “pluginname” folder on htdocs/[wordpressinstfolder]/wp-content/plugins, where [wordpressinstfolder] can be removed if you installed WordPress on the htdocs folder, with a FTP client like FileZilla or WinSCP, overwriting all the files.

Whenever you install or update plugins, WordPress enables a Maintenance Mode which disables the website while the software is being upgraded. If the installation completes (successfully or not), this maintenance mode should automatically be disabled again.

If it doesn’t, you can manually disable maintenance mode by removing the .maintenance file, like @Ergastolator1 said.

If you’re consistently having trouble installing a particular plugin, then manual installation is probably the way to go.

@Ergastolator1 & @Admin Thanks for your reply.

I have tried that and after that, it’s working fine. But another issue is showing that WordPress 5.2.2 has some issue because after updating it few of plugins update installation error occurs.

could you guys help me how can I fix that issue?

That’s direct install by the FTP or by the file manager upload the plugin then unzip, which is an alternative option but how can I install directly by the WordPress plugin through the ADD NEW plugin option.

Uploading the zipped plugin then unzip it doesn’t work with zip files bigger than 10000 KBs (10 MBs). You must unzip them from the computer and upload the respective folders of the plugins on where you’ve installed WordPress/wp-content/plugins, overwriting the existing files.
The max file size limit and execution time are set respectively to 10 MBs and 20 seconds to prevent hackers from abusing the service. To upload bigger files or want a bigger execution time please consider upgrading to Premium Hosting as the limits are not present or unzip the files (if they are zipped) and upload them.

That honestly sounds like it’s a problem with the plugins not working with the latest WordPress version.

And if they support the latest WordPress version, we also replaced PHP 7.0 with PHP 7.3 this week. So if these plugins don’t support PHP 7.3 (yet), then that would explain the issue as well.

If so, I can’t think of any workaround or fix, except for wait for the plugins to be updated or replace them with other plugins which offer similar functionality.

@Ergastolator1 & @Admin thanks once again.
currently, I followed @Ergastolator1 steps and that worked for me. Thanks once again.

if in the future I will get an issue then get back to you guys. :slight_smile:

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.