Setting up Web Hosting

Username (e.g. epiz_XXX) or Website URL


Error Message

The login is invalid.

Other Information

I am trying to set up free web hosting. I downloaded WordPress and get to the CPanel login, except it doesn’t work at all, no matter what username and password I put in. Any help would be greatly appreciated. Thanks (:slight_smile:

the cpanel login user name and password should be the email address and password you registered with

1 Like

If you log into the Client Area, all you need to do is click the “Control Panel” button. And unless you recently changed the Hosting Account password, all should work fine.

@lovebug What you are describing is the login to the Client Area, not cPanel.

And @michaelacaggi Why not just install Wordpress through Softaculous?


Welcome! The button in the client area will auto-login for you when you click it. If it does not work, please select “Edit Account” in the client area and change the account password. Wait a minute or two, then try again.

@lovebug, the cPanel password is not the same as your signup details. It matches the hosting account details.


sorry my mistake :frowning:

on my cpanel the password IS the same as my main login

------------ edit ------------------

erm now im not sure what my password is !!!


2 posts were merged into an existing topic: Sorry

It looks like this and still gives me an error:

I have installed WordPress through Softaculous.

Sorry if I wasn’t clear, I mean the cPanel login when I press on my website admin - to edit it.

1 Like

You need the direct Softaculous option from the control panel.

1 Like

Here’s what I do: I go to Softaculous → Click on my installations → Then click on my admin person button, and it either sends me to the cPanel login which does not work, or gives me an unsecured server error.

Can you screenshot this button? I am not sure what you are talking about.

Also, can you please share your account username?

Thanks, everyone for your help. I figured it out. By reinstalling WordPress, I had to leave it at HTTP instead of https.

If you want HTTPS, install your SSL certificate first, then add the ReallySimpleSSL Plug-in.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.