Setting my subdomain as default domain

Username (e.g. epiz_XXX) or Website URL

Error Message

NO DOMAINS ON ACCOUNT: Cannot change or set new DNS in CNAME Records

Other Information

I want to set new cname like ns1.epizy but can’t because of this “no domains on account” even if i have domains on the account the cpanel can’t see them.

You can get free domain from Freenom.
If what you want is get free ssl, screenshot your CNAME records in the VPanel and wait for admin…

here’s what i get

You hv to wait for admin as he’s in a different time zone…

Hmm, that definitely doesn’t look good.

If I had to guess, this is caused by the difference between subdomains which are created when the account is created and those which are added later on (hence why the former are in the Addon Domains section and the latter are in the Subdomains sections). If so, that might just mean why you can create CNAME records for some subdomains and not for others.

I’ll need to do a bit more investigation to be sure that this is the case and see if that can be fixed.

But if you don’t want to wait for that, you may be able to work around this by removing the subdomain from this account and creating a new account for it instead.



I’d like to wait for you to repair the problem, time is not a problem for me.
Also, when the job is done let me know couse i want to install SSL certificate on the website from the client area.

Thanks :slight_smile:

The issue has been fixed now. You can now add CNAME records to any subdomain on your hosting account, including the ones which were added later.


Great!! The domain now shows up but after entering the record name and destination I get an error#96328489

1 Like

Wait for @Admin to respond, only he can resolve the problem.

1 Like

@mmaklilu did you tried to select an subdomain when you added a new CNAME?

If YES: that’s why gave you that error.

If you’re trying to install an SSL certificate you need to follow these exemples:

If you’re using Let’s Encrypt:

  1. On the SSL domain main page, you’ll see two CNAME records: one for _acme-challenge and one for _acme-challenge.www, each with their own Destination. These are the records you need to add.

If you’re using GoGetSSL:

  1. Click the Request SSL Certificate button, or click the Pending certificate already there.
  2. On this page, you’ll see one CNAME record, with a destination ending at . This is the CNAME record you need to add.

You should keep this browser tab open, because you’ll need these records later.

If not installing SSL certificate, you need to contact an Admin.

1 Like

Yes I did.

Sorry about that. It appears that the fix wasn’t done properly. I’ve asked iFastNet to check.


Where you able to do what you wanted to do?

The issue should be fixed now.

Thanks, I just tried to do it again and still got the same Error #96328489 Sir. Should I wait for a while and try it again?

I’m terribly sorry. I got confirmation from iFastNet that the issue was fixed and blindly relayed it without testing. It is indeed still broken. I just informed iFastNet about this too.


No worries! I actually created another account and it’s working fine on the domain. I appreciate all the help.

Sorry for the late response. Everything should be fixed now!


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.