Redirect to /?z

My website URL is: []

What I’m seeing is: the website has been redirecting to for more than a week. I am wondering if you could help me as most people in other topics say after the 72 hours it fixes its self but mine has not. the message on just says "This will only take a moment. Please wait… " with three loading blue dots.

I’m using this software: Only infinityfree supplied software on google chrome ( Version 73.0.3683.103 (Official Build) (64-bit) )

Thank you in advance for your help

Same problem with my site.

If you disable your ad blocker, you will be redirected to a scam advertisement page instead of a blank page with ?z in the URL.

It still happens to me from time to time even more than a week after setting up my web site.

Same problem. All Domains redirecting /z
Please Fix

It looks like your DNS records have somehow gotten messed up. Can you please try to remove the affected domain name from the account and add it again? That should reset the DNS records and bring your domain back online.

Note that it may take up to a day for the fix to start working though due to DNS propagation.

Why would all 3 of our DNS records get messed up at the same time?

i’ve same, that gave me ?i in my site, why?

I got the same problem here, website is and, we all have this problem on the same day, I had this from earlier today. It can’t a cooincidence something must be wrong with infinityFree perhaps

On I haven’t the ?i=1 in front of the URL. On I see an ?i=1 when using incognito mode. Try applying Cloudflare even on and the ?i=1 will disappear. After that, install on your computer or phone and see the results.

There is only one DNS records for your domain, and five different nameserver addresses. But these five addresses are not five physical servers, they are actually separate clusters of servers around the world. And it seems that some of these clusters have gotten out of sync. The easiest way around that is to delete and add the domain again, which should force the nameservers to update.

?i and ?z are not the same thing. The latter is from the parking pages, the former is completely normal and is explained here:

The first domain is not in use on an account right now. The latter is working fine from here, which means the solution I proposed above may work for you as well.

I can confirm this has worked.
thank you

How do we make sure this DNS bug won’t happen continuously? I don’t want to delete and re-add my domain every week. Or even every month.

I believe it is a one-time setup issue as I have had no problems with any other sites

I don’t know in your case, but in mine my web site was created, then worked for a few days, and then didn’t.
I understand deleting the domain, re-adding it, waiting 3 days fixes the problem. But if I had to do it now, will I have to do it again?
There doesn’t seem to be any acknowledge of a problem by infinityfree. As if it were business as usual to have to do this.

If you’re hosting hundreds of thousands of websites, then random glitches are inevitable. If such a glitch happens once or twice and can be fixed with a simple workaround, then that’s often good enough as a way forward. If it happens more often, then of course we should do something about that.

That said, the stability of the nameservers is something that iFastNet is actively working on. But they are working to improve the system as a whole, not to fix individual domains.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.