Rederecting & SSL

Hi there all

i started to build my own free website on with the URL (
After building & trying, i bought my own domainname @ an other website.

To link those 2, I added an ‘addon domain’ in my Cpanel ( and imported my items in the htdocs from this domain. After this, i pointed my DNS-servers in my domain website to Cloudflare and activated Flexibel SSL.
Now i have 2 problems :frowning: :

  1. My HTTPS is still not working while the certificate on Cloudflare is active. When i do my “WhyNoPadlock” i sometimes got 2 errors : Force HTTPS (what i have activated in cloudflare and my .httpacces - file) + mixed content ( i do’nt have mixed content i think …).
    How can i get this OK?

  2. When i use Edge and i browse to - it still redirects me to the free domain (and there are no files anymore) - how is that possible? How can i stop this? Do you guys get HTTPS or redirected?

THank you already.

Hi and welcome to the forum

do you mean under the term “link those 2” this:
if someone visits
to take him automatically to ?

if so, then you need in htdocs of
create .htaccess file with this content

# Redirect  
Redirect 301 /

but do not do it until you solve the problem (2)
because you will create a redirect loop !

why indeed redirect to ? you have to check out .htaccess, html, and other possible files and see where there are **that 301 redirect** and remove it (also check on cloudflare, page rules,etc.)

You should never use Flexible SSL on InfinityFree. Flexible SSL is only useful if the source server does not support HTTPS. However, all websites on InfinityFree are HTTPS enabled by default so you can always use SSL Full

I second all that @Oxy said, with one addition:

If you use a CMS like WordPress, note that you may need to change the configuration of your website as well to use the new domain name. For WordPress, you can do that through the wp-admin, but steps vary depending on the software you’re using.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.