Really Simple SSL error (self signed certificate)

Dear sir/madam, im trying to setup a fresh website.
The first thing im doing is trying to get the SSL working through cloudflare. This all went smooth, nameservers changed etc. But then after installing the Really Simple SSL plugin on the wordpress website, it started giving an error. I tried debugging and it gave the following. Hopefully you know exactly how to fix this.


  • WordPress redirect
  • Mixed content fixer
    SERVER: apache
    SSL is enabled for this site
    ** Detecting configuration **
    plugin version: 3.2.3
    Already on SSL, start detecting configuration
    ** Configuring SSL **
    testing htaccess rules…
    test page url, enter in browser to check manually:
    htaccess rules test failed with error: cURL error 60: SSL certificate problem: self signed certificate
    checking if .htaccess can or should be edited…
    .htaccess does not contain default Really Simple SSL redirect
    retrieving redirect rules
    converting siteurl and homeurl to https
    Could not connect to website
    .htaccess does not contain default Really Simple SSL redirect

For me it redirects too many times (aka gives me an ERR_TOO_MANY_REDIRECTS error). From the Cloudflare dashboard select the domain you precedently added, then click on “Crypto” and change the SSL option from “Flexible” to “Full”.

I had used Really Simple SSL and i know why TOO MANY REDIRECTS error is being caused. The main reason for that is you are using both wordpress redirect and .htaccess redirect. Try using only one redirect at a time from Really Simple SSL Settings.

It seemed to work for a moment. but then again it gave the same error. That is strange. How can I remove the SSL part from the wordpress side?

Your website is working fine for me

1 Like

An error on verification of SSL for my infiniyfree account by As below msg and how to resolve?

Domain “” challenge3 failed. Response from “” was:

Warning: Your verification URL is not returning the correct contents to our verification servers. The URL looks like it is blocking bots and which inadvertently blocks our servers from receiving the correct content. Contact your host, a professional developer or admin for further help with fixing it.

InfinityFree blocks Bots that try to access your website.The only bots which are normally not blocked are those from Search Engines. (Crawlers)

1 Like

Also, using Cloudflare doesn’t work with subdomains. So you need to buy a domain or use a free domain from Freenom that you need to point to the nameservers and and add on a hosting account here on InfinityFree.

1 Like

Is that only solution? I got one domain .tk (from freenom). but can’t be used it cos infinity was banned to this domain.

The .tk domains are banned from this hosting due to abuse. From Freenom, pick any other extension, except the .tk one, if you really want a free domain.

1 Like

ive got the .ga domain and it isn’t working either. Is that because of the same reason? (See the really simple ssl debug ive posted above in the first post)

Leave that self-signed certificate thing alone on Really Simple SSL. That’s normal, just because there is no signed certificate on the server, but on Cloudflare’s reverse proxy system there is one.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.