Problem setting up the SSL/TLS with certificate generated by Let's encrypt

Username (e.g. epiz_XXX) or Website URL

username: epiz_28647637

Error Message


Other Information

I am using free hosting plan and have a problem setting up the SSL/TLS.
I generated a new “Let’s encrypt” certificate using the tool and got a private key and certificate. Successfuly uploaded the key and the certificate in the cpanel. However the when I tried to open my domain with Chrome I got the following error: ERR_SSL_PROTOCOL_ERROR

I tried to diagnose the problem with openssl

openssl s_client -connect
139810635650304:error:14094438:SSL routines:ssl3_read_bytes:tlsv1 alert internal error:../ssl/record/rec_layer_s3.c:1399:SSL alert number 80
no peer certificate available
No client certificate CA names sent
SSL handshake has read 7 bytes and written 176 bytes
Verification: OK
New, (NONE), Cipher is (NONE)
Secure Renegotiation IS NOT supported
Compression: NONE
Expansion: NONE
No ALPN negotiated
    Protocol  : TLSv1.2
    Cipher    : 0000
    PSK identity: None
    PSK identity hint: None
    SRP username: None
    Start Time: 1621376327
    Timeout   : 7200 (sec)
    Verify return code: 0 (ok)
    Extended master secret: no

I verified that the private key is 2048 bits (with openssl rsa -in private.key --text -noout).
I tested the certificate inside local nginx and hardcoded ip address of in /etc/hosts, and Chrome recognize the certificate as valid, so at this point I think the private key and the certificate key are generated correctly.

What could be the problem? Is there any additional step that I need to do in order to configure HTTPS?


2 posts were merged into an existing topic: SSL not working