Problem installing PHP script

I ran into this PHP issue while doing the installation.

  • PHP-CLI version

PHP-CLI 7.3 or higher is required.

  • PHP escapeshellarg() function

The PHP escapeshellarg() function must be enabled.

  • PHP exec() function

The PHP exec() function must be enabled.

please help me fix this problem i don’t know how to attach jpeg files here

Welcome! PHP command line functions are not supported on free hosting.


Hello, thanks for your answer. Please tell me how to edit files on the server?

You can…

  1. Open the online file manager, find the file, and click “Edit”

  2. Download the file using FTP software like FileZilla, edit it on your favorite code editor, then upload it back to the server (recommended)

1 Like

Thanks for your answer. I do just that, but the problems remain such a feeling that it’s impossible here at all. I can’t run a single PHP script that I could do on other hostings here, sorry

What do you mean? Besides the CLI functions, what is preventing the script from working?

1 Like

I can’t understand yet, maybe I entered the wrong mysql data Although I have already tried all the options

the script is installed True, all folders are present, this is displayed in the following link, but the login to the script control panel does not exit

unfortunately we couldn’t wait for help, nevertheless thanks for being in touch))

$db['default'] = array(
	'dsn'	=> '',
	'hostname' => 'localhost',
	'username' => 'epiz_30741517_webview2',
	'password' => 'XYXYXY',
	'database' => 'epiz_30741517_webview2',
	'dbdriver' => 'mysqli',
	'dbprefix' => '',
	'pconnect' => FALSE,
	'db_debug' => (ENVIRONMENT !== 'production'),
	'cache_on' => FALSE,
	'cachedir' => '',
	'char_set' => 'utf8',
	'dbcollat' => 'utf8_general_ci',
	'swap_pre' => '',
	'encrypt' => FALSE,
	'compress' => FALSE,
	'stricton' => FALSE,
	'failover' => array(),
	'save_queries' => TRUE

Not localhost !
but look at which database server is listed in the client area

when you choose your hosting acc
then you have this as a side menu on the left side
click here and read

Your username is also wrong !
And do not publish the password publicly !


I can’t figure out what database name to enter

Please see the information in the “MySQL Databses” section of the control panel for the database name.

1 Like

Everything worked out! Thank you


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.