Preserving Timestamps

Username (e.g. epiz_XXX) or Website URL

Hello, I’m brand new to InfinityFree and trying to get my web site running. I was running a site on another platform so I already have a bunch of files to transfer. Is there an easy way for me to upload them and preserve the existing time stamps?

I’m not familiar with the Monsa File Manager, but on my previous platform the included File Manager had the ability to create/extract compressed files so I would typically zip/tar a bunch of files, upload the zip/tar, then extract them using the File Manager to preserve the time stamps. That process worked well.

I was wondering if there’s similar capability here. Thank you

You can upload zips and tars through Monsta online FTP, but I wouldn’t recommend it, it crashes a lot and has lots of errors.

Instead what you should do is get an FTP client, such as FileZilla. Check the “Free FTP Software” section in the control panel.

Yes, using FileZilla (or another FTP software). Read this article to learn how to preserve timestamps on FileZilla:


Thank you!

1 Like

Also, if you don’t want to download an FTP client, you can use this online one I use all the time:

(change language to english)

No problem!, if the answer helped mark it as resolved so other people can also see what worked for you!

Username (e.g. epiz_XXX) or Website URL


Hello, I’m encountering a strange FTP issue and not sure how to resolve it. I’m using WinSCP to upload files to my newly created site and I’m noticing in Monsta that the timestamps aren’t being preserved. I’m using the same WinSCP scripts that I use daily to transfer files to various servers and have never seen this issue. The timerstamp is always properly preserved. I even tried forcing it with the -preservetime flag on the put. As one last confirmation I transferred the same file to my site here, and a second location using the same WinSCP script. The timestamp is properly preserved in the second location, but no matter what I try InfinityFree always generates a current timestamp.

Do I need to configure something in my account?

Also I manually FTP’d into my site and did a directory listing which showed the file with the current timestamp so I know it is not a Monsta issue.

It’s imperative that I upload certain files to my site with the correct (and accurate) time stamp for record keeping.

Thank you

Please see the link shared above by @FreeServices.

Which link are you referring to? My question is in regards to configuring my account and/or behavior of the server. Thank you.

This link:


OK yes thank you, I did see that. So let me back up. When I asked the original question about Monsta capability and saw the replies that essentially I should be using an FTP client (FileZilla, WinSCP, etc), I immediately updated my existing WinSCP scripts (that I’ve been using for a long time to transfer files to several locations) and began uploading files to my site. I then noticed the timestamps weren’t being preserved here. I’ve never had that issue before … they are preserved on all the other servers I transfer to. I did look into the WinSCP documentation, and tried the flags but it’s still not working. So I thought perhaps I need to set something up in my account to ensure they get preserved.

Thank you again,

1 Like

I’ve tried everything I can think of and find within the WinSCP Client settings including following the instructions in the EGNYTE article and nothing works. Has anyone been successful at preserving timestamps on InfinityFree servers using WinSCP? If so, I’d be grateful for explicit instructions on how you configured it.

If not WinSCP and you successfully preserved time stamps of uploaded files with something else (e.g. FileZilla) please confirm which and I may switch to that solution.

Thanks you

I don’t use WinSCP but I know for sure that FileZilla works. Just use Ctrl+U to enable it. Here’s a screenshot:

Screenshot (212)


Thank you for the reply. Believe or not, I went ahead and installed it and just tried it 10 minutes ago! It’s still not working for me even with the Preserve Timestamp option checked. Are you using FTP or SFTP and specifically which FTP server are you connecting to?

Example of one file I just uploaded with FileZilla
Timestamp of file on laptop (3 months ago)
Timestamp of file after upload (A few minute ago)

port: 21

Just did a test and the same happened to me, unfortunately. This popup box showed when I first tried to select that option and it said :
So I guess that InfinityFree doesn’t support MFMT command? Honestly, Im not sure

Maybe trying to change the date on your computer to the timestamp you want will work? I have no idea because I haven’t tested this, this might be a really stupid idea



I sent a raw FEAT command via the console

and as you see



This command is also frequently used in a non-standard fashion to set file modification times. Both the standard MDTM command for retrieving file times and the non-standard use for setting the date/time on a file.

Probably then you can use that option (MDTM) if a particular FTP client has that capability

Of course there is a possibility that the server strictly follows the RFC rules and then does not provide the ability to edit the timestamp (set) through that command .


…refers to a specific FTP server product from that Egnyte company. It doesn’t say anything about the FTP protocol in general, the PureFTPd server we use, or the way it has been setup here.

I can’t easily tell if PureFTPd does support MFMT and whether we allow it on our server. But the output shared by @Oxy seems to imply it’s not supported.

I wouldn’t be surprised if it’s not supported. File timestamps are useful for many reason, but then we do want to have the actual timestamps, not something arbitrary set by the user.

I do wonder why you need specific values for the timestamps in the first place.


Thank you again to everyone for all the help and support. I guess this is the expected behavior. I will try to figure out a solution. I have common files/code I keep synchronized across multiple platforms and rely on maintaining correct file modification timestamps to assist with the synchronization. I didn’t see any mention of a GitHub interface in Control Panel so I don’t think that’s an option here either.

Thank you again, very much appreciate all the help.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.