All emails are going to user spam folder
I am using PHPMailer. Emails are going fine but only thing is all user email are going (landing) in user spam folder, I tried few things but nothing working for

I have tried the same thing on my local server using working fine but not on ifastnet hosting.

Kindly someone please have a look

Kind Regards

hmmmmmm, interesting.
was your domain recently registered, because gmail doesn’t like new domains…

Yep that’s true. Its my profile page. I registered it 2 months ago.

Please note that this is the InfinityFree forum, not the iFastNet forum. If you need help with premium hosting, please use iFastNet’s ticket system instead.

But what I can tell you is that spam checking is done by the recipient mail server, not the sending one. So it may just be that the mail provider of this “user” just doesn’t like you or your email.

What can help is to send a test email with, which can usually help indicate configuration issues you can use to increase your chances of mail being accepted.

But in the end, it’s still the recipient email provider doing the spam filtering, so even if you everything right they may still consider your email spam.


Generally “spam” emails are detected by the incoming server checking whether or not there is a DKIM Record for that domain. They act like an Email Certificate, verifying the sender, preventing the incoming server from reading it as spam.

This would automatically be provided by Google, so no need to worry about that.

The next trigger that incoming servers look for depends on the content of the email. The incoming server may detect the email as “spam” depending on its content. Perhaps try checking your email content and make sure it doesn’t seem like a spammy email.

The last thing could actually to be with your PHPMailer settings. I noticed your using Port 290 as the outgoing port. When using an SSL Connection you should use port 465.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.