Error Message

I’m using a free account for a month or two.

I have some large PHP/MySQL applications(one being simple webshop)

that I’m testing (bought from third-party).

I was frequently updating the database/system yesterday,

and everything went fine.

The next day on all 3 applications login screen I see

only one massage: Ow==

Don’t have the slightest cloue about what it means…

I had 4th database/application that I couldn’t install before,

thought maybe it’s some issue with MYSQL bandwidth and

removed the database. The same.

Other Information

This appears on the first line of the blank page. Interestingly on a third

application, if a reload the page for couple of times it gets

to login screen but after I log in, it’s the same error.

Any help would be appreciated, thx.

Nor do I! But it’s very strange, unusual and rare, so I really can’t say much. The only thing I could say (though I might be wrong) is that you could have been hacked. Change your database and FTP password in the client area.

I’ve managed to turn some error repporting on in the application.
It says unserilize() has been disabled for security reasons.

All my other php files work outside application folder, and all files in the applicattion folder(html, php) that has nothing to do with database work too.
I’ve tried to install the application fresh. The samme error.
Before, it installed without problemes.

This must be database security issue because of free account, that has been disabled, by the free webhosting/system.

Just want to be sure 100%, before I have to upgrade.

Any thoughts?

If you told that you were using WP before, then it would’ve been easier for us to help, but anyways, it looks like you’ve done a good job identifying the problem yourself!:+1: And yes, you are correct that unserilize() has been deactivated by iFastnet. You will have to upgrade, but I’m not sure which plan allows the function as it does have a security issue. I believe the best place to ask questions about the paid plans would be by contacting ifastnet.

*Sigh, they’ll fix it after few days. Not perma-disabled.

I have to upgrade, and will contact iFastnet.
I’m not using WP :slight_smile: :slightly_smiling_face:
(maybe that part of application is using WP architecture)

Ah, I seem to have misread it because of my bad eyesight! It looked like WP to me. Glad to help you.

If you decode Ow== in any Base64 decoder, you will get one semicolon, just semicolon

The unserialize function was disabled in our PHP 5.4 setup, presumably due to unsolved security problems in that version of PHP. PHP 5.4 stopped getting security in September 2015, so issues like that are bound to occur.

The best way to fix this is to run your website on a newer version of PHP. If your website code supports it, you should just switch to the newest version of PHP (which is 7.4). If that doesn’t work, you can try to use PHP 5.6, or at least the newest version of PHP your site can run on.

If your website really doesn’t work on a newer PHP version, you may want to consider updating your website or switching to software which is still being supported. Because PHP 5.4 is very old by now.


Thx, man… It resolved the issue!
It’s because I was experimenting with control panel and php versions, at the end of the day(without noticing it can change/break anything)

It works perfectly again! what a sight.
I’ve changed it to the latest php version in control panel, 7.3.
it did not work with other versions.

Also, I thought, php 5.x was still fine. Have to upgrade(xampp).

1 Like

Glad to hear it!

Nope, it definitely isn’t! Even the latest version of PHP 5, which is PHP 5.6, stopped getting security updates after 2018.

And as a rule of thumb: you should always try to run the latest released version of PHP. Most versions of PHP only get a few years of security updates.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.