Original Server Certificate

When I try to add an original server certificate for my domain name, (I would not like to disclose the domain) It says its not for the domain I tried to add it to. I am 100% confident that it is the correct domain. The cPanel recognises that it is a Cloudflare CA certificate. This is just for a temp uni project. I do client projects (But I can’t call this a client project as its my dads lol) and I have access to his hosting account and I added the same domain name and I added the same certificate to it and It fully worked. (Its on shared hosting by the way) I wonder why this doesn’t work.

The cloudflare origin certificate doesn’t work as it is not trusted cert

1 Like

Hmm. I switched to Cloudflare as my InfinityFree SSL showed up as not trusted in Firefox and other web browsers.

Tryna use flexible mode in CF

1 Like

no full strict. ik that it works for flexible but I like it strict!

I have seeeeeerious trust issues with flexible

Read this:


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.