Only TLS 1.3 available

I’m using free hosting at infinityfree and also free SSL certificates, for years already. The problem is that on all my three hosting accounts, there is no support for TLS 1.2, and that started only a week or two ago, and is making me some trouble. When I run the tests on for all three of them, I get the same result, that only TLS 1.3 is supported, and that they do not communicate any more with TLS 1.2, which matches my experience.

Is this intentional?

What do you mean?
Write clearly


Hi dragoljub,

This is not a question, as it’s universally describable, I’ll consider your questions as how to support all protocols for free for your case instead so you stop suspecting the intentions for providing you free SSL certificates supporting TLS 1.3 in the first place (if you know what I mean, or you can explain yourself).

In reality, most SSL certiicate only supports TLS 1.2 or above as they are considered secure in the modern era, TLS 1.1 is already considered “not as safe” due to algorithm age. However, you can get a free fully supported SSL certificate from Cloudflare if you use a custom domain and use that on this hosting absolutely for free.

Read through the documentation and find articles on

  • how to get a free domain from
  • how to connect custom domain using Cloudflare to IF
  • how to make the SSL connection fully SSL

While the intention from your question is highly speculative, I prefer not judging your tone, but from a general perspective this may potentially cause hard feelings for anyone trying to read it, even if you do not intend to do so.


@dragoljub image

Not correct

look here:

other versions below 1.2 are not safe and should not be used


Ok, guys, I am sorrry, I do honestly apologize for the lack of context! It was quie late last night when I just wanted to post and think later. Thank you very much for taking time to reply even to such question!

No, no, no, Oxy, you will not trick me! :slight_smile: It is working now, reports 1.2 too, but it did not for at least 10 days! I bet the admin saw my post and fixed the problem. Thanks, admin!

1 Like


The page is working but the test is not working and various combinations up to that point
that there are times when the server is completely dead.

Maybe they had problems just like now or the result was one from their cache :slight_smile:


Ok, I don’t know about the reputation of SSL Labs, but I do know TLS 1.2 did not work for me, myself and I, for the last 10 or so days. That is why I ran the tests in the first place. To be honest to SSL Labs, I did also use two other random sites to test SSL version, the result was the same. And then it magically started working again the day after I posted my question.

1 Like

Hi dragoljub,

Just in case, you can forget SslLab and use the highly reputable Mozilla Observatory, it is developed by a browser company, an open browser that does not relies on Chrome tech, and most importantly it is community driven.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.