Omeka Classic Error


I installed Omeka Classic to do an oral history assignment, for it to serve as a repository for these interviews. But I need to configure the OHMS plugin to be able to link these OHMS interviews with OMEKA, but in the configuration I can’t find the “background.php.path”. With the Reclaim Host site, this option within the OMEKA config.ini, would be “/usr/local/bin/php”, using Infinity Free how would it look?


Can you please link to the plugin you are trying to install?

InfinityFree does not allow to you save any files outside of the root (/htdocs), and if my memory serves me correctly, /usr/local/bin/php is the location where PHP is installed on the server (May be wrong).

Without more information, I really cannot help you.

Hi, @Greenreader9 thanks!

Are these two plugins

GitHub - libmanuk/OhmsImport: Upload a valid .zip file containing valid OHMS XML files into Omeka. and GitHub - libmanuk/OHMSObject: An Omeka plugin that embeds an OHMS Object via a URL in the OHMS Object field.

I follow these user guide - htt ps://www oralhistoryonline org/wp-content/uploads/2018/07/OHMS-Plugin-Suite_v1-1-1.pdf

Ah, I think you are referencing this, correct?

You want to look in /htdocs/FOLDER_NAME/application/config/config.ini, replacing FOLDER-NAME with the name of the install folder.


Oh wait, that is the path on the config file, right?

Since you cannot access files outside the root, can you try moving the background.php.path file to an accessible directory, then changing the file path?

I referencing this part

Personally, I do not understand what it wants. Can you try leaving it blank and see if it will auto-detect like it says? If not, you will have to wait for Admin.


Okay, I’ll leave it blank and see if it works. If not, I’ll wait for an admin. Thank you for the support!


I left that field blank and followed the plugin installation, then when I use it I get this error

LogicException: OHMS file must be validated before retrieving list of column examples. in /home/vol6_8/
Stack trace:
#0 /home/vol6_8/ OhmsImport_File->getColumnExamples()
#1 /home/vol6_8/ OhmsImport_IndexController->indexAction()
#2 /home/vol6_8/ Zend_Controller_Action->dispatch(‘indexAction’)
#3 /home/vol6_8/ Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http))
#4 /home/vol6_8/ Zend_Controller_Front->dispatch()
#5 /home/vol6_8/ Zend_Application_Bootstrap_Bootstrap->run()
#6 /home/vol6_8/ Zend_Application->run()
#7 /home/vol6_8/ Omeka_Application->run()
#8 {main}

It took me a while to understand what the option does:

; Background Scripts ;

; background.php.path
; Path to PHP-CLI for running background processes.
; default: ""
; If left blank, Omeka will try to autodetect the right path. Set this
; to override the autodetected PHP path.
background.php.path = ""

I think it wants to know where it can find the PHP executable, so it can call it from the command line to execute background tasks.

The thing is that all command line related functionality is disabled on free hosting, and we do not allow background processes to be run.

So if Omeka Classic requires command line access to work, I’m afraid you cannot host it on our free hosting.

Premium hosting does support command line functions though.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.