NS records on subdomains in Cloudflare

Nope setting up NS is a free feature and I had already used it on free plan.

In the screenshot above that NS type in DNS allow you to setup NS for subdomain.
And yeah I am on free plan.


You can add the records, but they won’t do anything. They won’t appear at all on your domain. If you scroll down, it says Custom Nameservers, and it also says its a business feature.

1 Like

It’s working fine. There are numerous Let’s Encrypt users here who can testify that it’s working perfectly.

Note that not every hostname is serving a website. https://smtp.gmail.com is also “not working” as a website but working perfectly fine for sending email.

Yes, they do. You can delegate subdomains to third party nameservers. This is what we do with acme.infinityfree.net. infinityfree.net is hosted on Cloudflare but acme.infinfinityfree.net is hosted on Amazon. This works fine in Cloudflare.

We’re not on a free account but I see no reason to believe that this would not work on a free account. It’s just basic DNS management. Cloudflare doesn’t limit that for anyone.


They do work. I once used this feature.

Have a look at screenshot and now check http://nstest.aavidtutorials.com/
The domain is working fine with NS records.


I’ve tried it before and it doesn’t work. It also then makes the Custom NS pointless.

I did a WHOIS test on the domain nstest.aavidtutorials.com and it shows no NS.

You can’t use domain name with infinityfree free servers without pointing nameservers.
And my domain is not hosted by free servers so how you think I made an account for subdomain without pointing NS?

1 Like

Actually it does, but it’s still propagating:


I’m splitting this topic here. I like the discussion about Cloudflare’s features, but this is not really relevant anymore to the original question being asked (which is already marked as solved.)

It’s not the “Custom NS” feature. “Custom NS” is a white labelling feature for Cloudflare’s nameservers.

Setting NS records on subdomains is not a special feature. It’s just DNS management. Any DNS provider that claims to offer full DNS management should be able to do this.

That’s because the WHOIS input doesn’t show all DNS information. It only shows the registration information of the domain name. And the domain name, aavidtutorials.com, would then still be delegated to Cloudflare’s nameservers.

If you want to see how the DNS is resolved, do a DNS lookup. WHOIS is not always exhaustive and doesn’t always match what’s actually on the domain name.

You can use our Domain Checker tool for this. It does correctly resolve the nameserver chain.


Then probably acme.infintyfree.net is a domain that outside IP addresses can’t see. Because it is showing me this error, when I am opening the domain link :

This site can’t be reached

Check if there is a typo in acme.infinityfree.net.

  • If spelling is correct, [try running Windows Network Diagnostics](javascript:diagnoseErrors()).


Again, acme.infinityfree.net is not a website. Yes, it breaks if you try to open it in a browser. I know it does, because that’s how I set it up. But it doesn’t need to serve a website, it’s only used to delegate a subdomain to Amazon’s DNS for the purpose of setting up Let’s Encrypt verification.



This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.