Not allowed to execute, even with CHMOD

Website URL

Error Message

(please share the FULL error message you see, if applicable)


Other Information

(other information and details relevant to your question)

Hey there, IF, I’m doxr. I’ve noticed there is no terminal or ssh or anything like that. I tried to get a Terminal by installing PHP and creating a “terminal” (password protected, for now, the password is “doxr” but I will change it once this topic is marked as solution). I used the CHMOD button but it didn’t seem to help. Just to know if the code is the problem or the server, I ran it on my own device: it worked fine, I got responses. How am I able to run any kind on command? My end goal here is to be able to host my own software instead of having to use Softalicious.


It is not possible to run any sort of CLI or terminal-based commands here due to security reasons and past abuse.

Instead, please generate the files using the terminal on your personal computer, then upload the resulting files to InfinityFree servers


would something like uploading a nodejs proxy or a discourse forum (btw neat forum, I’ve never had it this good, lol) work? that’s my main goal. how do I use things like NPM or starting a webserver without a terminal?

Neither do we have Node.js or Docker (I believe this is the under-lying tech for Discourse forums).
For Node.js, you’ll need premium hosting.
For Dockers, even premium hosting don’t have it, and you’ll definitely need some VPSes / Dedicated servers. (Just wanted to say, while buying iFastNet shared premium is a good idea, buying VPSes from them isn’t :upside_down_face: )


cool, thanks, lol :stuck_out_tongue:


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.