No trusted ssl certificate found


Hosting Support

I have completed the steps to get a free SSL certificate and activated it (i didn’t create it but the service send it to me). My website works if I type https://www… but when I want to download the WordPress and use the https URL it says that it doesn’t find a trust worth SSL certificate.
How can I fix this?

Use CloudFlare

Won’t that affect my SSL certificate? I would need 2 diffrent name servers.
I had before 2 nameservers…from cloudfare and infinityfree and when i wanned to create a certificate it said i need to have only 1 nameserver(infityfree) if not the ssl certificate could have some problems or something

No. Just need to add CNAME to CloudFlare dns entry as well to maintain current SSL cert from InfinityFree as well as for renewal.

Is it possible that is only a catche? I sow that someone had same issues as me and tried everything and then admins fixed it.

Read this

Still the same :confused:

You are supposed to install WordPress w/o SSL. Use CloudFlare “https rewrites” to enforce https

I did the steps again and now I guess works. The only problem is redirecting. If I type only my domain it says that the website is not safe but if I type https://… says that it’s safe.
I checked on my phone and it redirected to https so it worked fine, but not on pc.

Did you enable “https rewrites” on CloudFlare?
Need to clr cache as well and make sure SSL is set to strict mode.

I created page rule and added SSL-strict, Automatic HTTPS Rewrites: On and on SSL/TLS is set on full(strict).
But I don’t know how to clear cache And WordPress was installed when the certificate was already maid

I mean clr your browser cache.
Sorry I made a mistake, CloudFlare SSL shd be set to Full, not Full(strict) mode.

Still the same, now both the SSL/TLS and rule page are set to Full. But I used the purge cache/everything, hope I didn’t mess anything up

I have installed a plugin **Really Simple SSL and now it works. It still says that some stuff needs to be fixed but the main problem is gone.
Thank you for your help!!


Glad to be of service…

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.