No ssl certification

Username (e.g. epiz_XXX) or Website URL
(please specify the website or account you are asking about)
i set up the ssl request 24 hours already passed , why it’s not working?

Error Message

(please share the FULL error message you see)
can only see the website with http :pensive:

Other Information

(other information and details relevant to your question)

Are you using infinityfree free SSL? If so, I can help you out with this.
It’s a good choice if you chose this option.
I’m not that experienced to answer your last question - Admin could probably help you with this
--------------------------IF YOU ARE USING IF free certificates --------------------------------------------
Sometimes, the SSL doesn’t load properly.
Go to Free SSL certificates in the navigation menu
In a new tab, navigate to Control panel > SSL/TLS

If you have done this already, re-upload the private key and the SSL certificate in this order.

Give it up to 72 hours to update

i have tried that method thanks , it gives an error of
—The private key you are trying to upload is not valid.—

What’s the actual domain name you’re talking about? The domain is not assigned to any of your hosting accounts.

As for your SSL certificate itself:

  • The SSL certificate hasn’t been issued yet. Please setup the CNAME records first as shown in the SSL Certificates menu in the client area, and wait for the certificate to be created for you.
  • Please make sure to upload the FULL private key AS IT IS SHOWN to the control panel. This includes the --- BEGIN PRIVATE KEY --- lines and such, they are an actual part of the private key.

that’s the correct site that i requested ssl certificate <<<------

you need to copy key, paste and then press Upload Key/CSR and do same with certificate

OK, I guessed as much.

In that case, please see my previous message, it tells you what to do next.

OK you do you say that your ssl certificate is not working? Check out the ‘cname records’ in Control Panel. If you have set up a CNAME records then cheakout your domain’s url. I mean the suppose you use, then you check the url at the top if it shows then change it to, if it shows SECURE then your website ssl is working all you have do is paste this code it your .htaccess file in your root folder :

RewriteCond %{HTTP_HOST} ^
RewriteRule ^(.*)$1 [P]

If it does not work then you have installed your ssl certificate in an invalid way.
Watch out this video to install valid account on your domain.


f[quote=“tejas100, post:9, topic:38507”]
e records’ in Control Panel. If you have set up a CNAME records then cheakout your domain’s url. I mean the
bro i tried everything

Where is the CNAME record?

did it but still no ssl verfied while being on website

If you hv setup correctly and DNS record (could take a while) is still not ready despite CNAME record entry, you hv to wait for admin

OK, it looks like your CNAME record has been setup successfully. So you just need to wait now for the certificate to be issued, which should happen soon.

After that, you’ll need to take the certificate from the client area and install it on your domain in the control panel. After that, you can configure your website to use HTTPS.

So no need to say “it’s not working the connection is insecure”. Yes, of course it’s insecure. It’s insecure because you haven’t installed an SSL certificate yet. And you haven’t installed the SSL certificate because it hasn’t been issued yet. That’s the step in the process where you are right now. No need to ask why step 10 shows no results when you’re still working on step 5 (numbers are for example).


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.