No SSL certificate was found

Username (e.g. epiz_XXX) or Website URL

Error Message

Other Information

Hey! After setting the private key & the certificate in the SSL Configure, the status of my ssl is to “No SSL certificate was found.” (See the screen above). Can i have help please?

I’ve never understood how to set up SSL with InfinityFree’s free SSL you can use other free SSL’s in the internet.

Do you have a tutorial or something about how to setup an SSL without the InfinityFree’s free SSL?
Thanks :slight_smile:

Personally, I use ZeroSSL ( It’s 90 days and I just put the cname records, pretty easy to set up. If it gives an error at the end just ignore it.

1 Like

I tried to use ZeroSSL but it don’t work… →
Any idea? :confused:

Cloudflare offers free Let’s Encrypt Wildcards now. Just go to cloudflare, signup, point your nameservers there, point a CNAMe record to your main domain. Change the SSL status to Full and install a self signed ssl. Done, you got a free wildcard ssl with a dedicated common name.


That’s what his/her issue is.

@ZeyXSkyHead, just wait. After both say ready, it can still take up to 24 hours for a certificate to be generated.

Yeah, when I tried to setup ZeroSSL, and tried to setup with CNAME records. But it said “Failed to verify” so I waited for 24 hours to take effect, and still it could not connect!


Thanks! It works perfectly with cloudfare!

1 Like

Have a similar issue here as well, but I don’t assume I could use @ZeyXSkyHead’s solution as Cloudfare are kinda biased with InifinityFree’s subdomains.

I followed all the procedures to the word through the instruction pages, but I assume the system outages may be playing a role here. Nevertheless, just wanted another opinion on the issue; if time is the primary solution, it’s not a problem.

TLDR; Don’t use ZeroSSL. You’ll waste precious hours/days.
The instruction pages mention the incompatibility of ZeroSSL for SSL certification, due to the presence of the Let’s Encrypt backend.


I like Zerossl, it issues unlimited 90 day Sectigo SSLs (even wildcards and multidomains) that autorenews. The condition is that you need to use acme

1 Like

Interesting, do you mind divulging a bit into the steps of interlinking the ZeroSSL certificate zip file (after issuance) with the SSL/TTS section in your (my) CPanel? I do have a valid certificate from ZeroSSL but on inserting it into the private key and certificate fields (as the steps dictate), the SSL certificate is still not found.

@SocialSites it does appear we have a common problem. Whatever solution the Admin may recommend, should work for the both of us.

I get this error while I upload my certificate, is it because of that?

At least I got the verification part completed, with help of a staff member. (It took them 4 days to respond)

CA certificate chains are not allowed in free hosting. You will need to use Cloudflare for that.

Well, this is a free service, and we are not staff, but free users like you.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.