No permission to write

Website URL

Error Message

Fatal error: Uncaught CodeIgniter\Cache\Exceptions\CacheException: Cache unable to write to "/home/vol13_7/". in /home/vol13_7/ Stack trace: #0 /home/vol13_7/ CodeIgniter\Cache\Exceptions\CacheException::forUnableToWrite('/home/vol13_7/i...') #1 /home/vol13_7/ CodeIgniter\Cache\Handlers\FileHandler->__construct(Object(Config\Cache)) #2 /home/vol13_7/ CodeIgniter\Cache\CacheFactory::getHandler(Object(Config\Cache)) #3 /home/vol13_7/ CodeIgniter\Config\Services::cache(Object(Config\Cache), false) #4 /home/vol13_7/ CodeIgniter\Config\BaseService::__callStatic('cache', Array) #5 /home/vol13_7/ CodeIgniter\Config\BaseService::getSharedInstance('cache', NULL) #6 /home/vol13_7/ CodeIgniter\Config\Services::cache() #7 /home/vol13_7/ CodeIgniter\Config\BaseService::__callStatic('cache', Array) #8 /home/vol13_7/ CodeIgniter\Config\Services::responsecache(Object(Config\Cache), NULL, false) #9 /home/vol13_7/ CodeIgniter\Config\BaseService::__callStatic('responsecache', Array) #10 /home/vol13_7/ CodeIgniter\Config\BaseService::getSharedInstance('responsecache', NULL, NULL) #11 /home/vol13_7/ CodeIgniter\Config\Services::responsecache() #12 /home/vol13_7/ CodeIgniter\Config\BaseService::__callStatic('responsecache', Array) #13 /home/vol13_7/ CodeIgniter\CodeIgniter->__construct(Object(Config\App)) #14 /home/vol13_7/ CodeIgniter\Config\Services::codeigniter(Object(Config\App), false) #15 /home/vol13_7/ CodeIgniter\Config\BaseService::__callStatic('codeigniter', Array) #16 /home/vol13_7/ CodeIgniter\Config\BaseService::getSharedInstance('codeigniter', NULL) #17 /home/vol13_7/ CodeIgniter\Config\Services::codeigniter() #18 /home/vol13_7/ CodeIgniter\Config\BaseService::__callStatic('codeigniter', Array) #19 {main} thrown in /home/vol13_7/ on line 66

Other Information

I’m trying to push a CodeIgniter4 project, but I can’t get the cache folder to be writable. I distantly remember that there is a writable directory somewhere on each account, but I cannot find it anymore. Is there a way to make this work?

Hi helloworld762,

All web folders on this hosting is 755 in permission, which is already writable. Meanwhile chmod() is disabled for security reasons meaning you cannot set folder permissions as well. In this case, you can check your .env file for the following values to see if they are under /htdocs, change them to something under this directory if not exist or not set so.


You might also want to refer to this for more information:



I believe the attempted path is already correct without me changing the configuration. Looks like this particular error was because I didn’t create the subfolders…

Now I proceed to a different error, I’ll see what’s happening next.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.