No comprendo la Configuracion de mi dominio

Dominio gratis: infinityfree (
dominio pago: DonWeb (
Hosting: Infinityfree
Servicio de Email corporativo: DonWeb

Estoy teniendo un inconveniente por que no estoy pudiendo hacer funcionar mi web o el servicio de email corporativo, me funciona uno y el otro no.
Consulte con el soporte de donweb y me dijeron que tengo dos opciones.

Opcion 1:
Modificar la zona DNS de mi dominio desde InfinityFree y agregar los siguientes registros: |MX| |A | |TXT| v=spf1

El problema esta en que no hay seccion den InfinityFree para poder agregar esta configuracion.

Opcion 2:
En mi dominio de DonWeb agregar los DNS de DonWeb que serian:
Servidor primario:
Servidor secundario:

Pero de esta forma la Web no se mostraria, entonces para que se muestren me tendria que pasar la gente de soporte de InifintyFree los registros para poder agregarlos en mi dominio.

Desde ya muchas gracias

Hi and welcome to the forum! Please note that this is an English-speaking forum and so you must speak in English or at least provide an accurate translation of your content. Since you didn’t do that I’m gonna translate it for you:

For the first option you might be able to add the MX and SPF records under the “MX Records” and the “SPF Records” section of the Control Panel, but the problem is that the record for the mail subdomain is an A record and so can’t be added, unless you do a reverse DNS lookup for the IP and add a CNAME record under its respective section with name mail and as destination the hostname the reverse DNS lookup returned.

For the second option (which is the simplest one in my opinion because you don’t have to do stunts just to add some records, but still requires to change DNS records) you can revert back to your domain registrar’s nameservers and then add two A records, one with as name your domain (or @) and another one with name www, that point to the website IP shown on the hosting account’s dashboard in the Client Area. Like so your website will still work and your emails will start to work as well.


Hello JxstErg1, thank you very much for the answer, perfect then, I’m going to make those changes and wait to see if it is solved.
Thank you very much for the prompt response.


1 Like

This post was flagged by the community and is temporarily hidden.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.