New SSL setup CNAME not showing

Website URL

Error Message

no CNAME found - Not ready

Other Information

I recently created an account with InfinityFree and I tried to create a free SSL cert for my domain and upon submission, I pressed ‘Setup CNAME Records Automatically’. I waited over 24 hours and when I checked DNS records online for different providers, the CNAME is not showing but it appears ok in the cPanel & DNS Records client area.
I tried to look at previous posts and someone recommended removing and adding again, which I have done.

Please let me know if I have done anything incorrectly, thank you.

Did you setup CNAME again afterwards? The DNS records are likely to be gone after deleting the domain.


Yes I set up the CNAMES again manually afterwards

Do you wait long enough? Note that most online tools will fail to read such an abstract record, you must check with the client area.


How long should I wait?

To confirm, I did not delete the domain. I only deleted the CNAME and added them again through the client area.

Normally 15-30 min, but can be up to 72 hrs.


The issue you’re seeing here is actually caused by a technical problem between our system and the free hosting platform. A quick fix is applied now, but we’re still looking for a way to properly solve this.


Thank you, working now

hello, i’m facing the same issue. cname added and still not showing after an hour. still same issue or i have to wait longer ?

Please note that on the page it says:

Please note that DNS changes can take a few hours to take effect.

Looking at the order, I see it was created around 30 minutes before you created this post. That’s not yet “a few hours” like we say, and not even “an hour” like you said.

I checked it now and it’s working fine. As we told you to: after a few hours.


i did wait more than 2 hours, then i delete it and recreated the cname before making this post

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.