Necessary Changes for my InfinityFree Hosted Website

Dear InfinityFree,

The following two requests are highly important, and I need both of them implemented if I am going to successfully host my WordPress website from your servers to the global internet, itself.

A) By default, the server directory on an InfinityFree free account starts within the /htdocs/
directory. For my own account, which corresponds to my email address HIDDEN BY MOD - [email protected] ,
could someone please update the webserver content reference directory to /htdocs/wordpress/ instead, please? It is the simplest step to get my relative links to work, without having to change so many of them them; instead only one thing needs to be changed, for my account: the starting directory to the webserver to detect web document files in. Could someone please make this change that I need?

B) I am having trouble getting my WordPress default page editor/free Elementor page editors to run without crashing. I have been shown via professional WordPress assistance that this is due to a lack of available memory for the software. Can someone please increase my memory limit to 512 GB on my “PHP INI”, presumably the one behind my entire account itself, so that I can run both of these page editors within WordPress, through my InfinityFree free account, for me, kindly, please? Without these editors running well, my website will not be able to be run and updated properly.

Can someone also issue a reply on this forum thread here when both are done correctly, also? :slight_smile:

Many thanks!

1 Like

No, this is shared hosting.
See below for more explanation

As for

You need to upgrade to premium hosting.
Elementor does not work well on free hosting


Setting custom web directories is a premium only feature. On free hosting, the directory gets assigned for you and you just need to work with that.

And it’s not like moving the files from htdocs/wordpress/ to htdocs/ isn’t that difficult. And if it is for some reason really impractical to move the files, you can probably hack around it with .htaccess rules.

I hope you mean 512 MB, not 512 GB. 512 GB is crazy, I’m not sure our servers even have that much memory. And no website should ever use that much.

But again, setting the memory limit is a premium only feature, although you’ll still have to remain within the memory limits assigned to your hosting account.

If you have a site that really needs more than 128 MB to run, it may be that the site is just too big for free hosting. Most sites run fine with that limit.


A) Can someone place a suggestion here with a code fragment so that I can, in my free account,
include something inside the .htaccess file to repoint my user content directory from /htdocs/wordpress to /htdocs/, since this is the easiest and most sensible approach to take? (It makes more sense for me to be able to change one thing like this, once, than many [complicated] things). :thought_balloon:

This site:

shows me that I should Redirect to a subfolder with URL masking:

RewriteEngine On
RewriteRule ^/?$ /htdocs/wordpress/

Will this line do the job, and run successfully for me, inside .htaccess?

B) I did mean 512 MB, not the other silly amount. There is nothing (beforehand) saying to people that (free) Elementor has running problems inside InfinityFree free accounts. What should such people do, if they go ahead and complete their website project beforehand, regardless? :sob:

At the moment, A) is more important than B), because I at least need a one-step, server solution for A) to even serve the website at all. B) Would be pretty useful, since making a change to my WordPress website and then uploading it all again through FTP has taken from 9 AM to 7:40PM. Doing a change to WordPress itself with my website, and uploading the whole lot again, as I presently have to do when you think about incompatible, different Database names (and that you start locally first, without any information from an InfinityFree free account), with FTP alone, requires more than an entire working day! Updating changes on the InfinityFree server, with the 512 MB of available RAM so that the Page Editors do run through the internet, makes much more sense, anyway, even on Free accounts.

Buy premium hosting.

This is why you should always have an end plan in mind, and if you don’t, if your winging it, that’s fine, but don’t expect everything to be free


This is why you should always have an end plan in mind

But even this information is not submitted to users before hand. What if the user is not in a position to Buy Premium hosting? Doesn’t it still make rational sense that free account should at least be able to do basic things, like run the default page editor, Elementor, and Gutenberg withstanding all that?

This site:

shows me that I should Redirect to a subfolder with URL masking:

RewriteEngine On
RewriteRule ^/?$ /htdocs/wordpress/

Will this line do the job, and run successfully for me, inside .htaccess?
Can someone please confirm that this will run and give me what I am after and am expecting?

Well, it can run the default editor. And I would not say Elementor is “basic”. It may be common, but it is not basic.

Basic is like the base. That would be the default editor (Which runs fine).

Elementor is like an upgraded editor that needs a lot of resources, resources that free hosting can’t have because nobody is paying for them.

Plus, a simple search for elementor on this forum will tell you that.

I don’t know. It’s code, it’s very hard to tell if it will work unless you try it.

Plus, it only takes a minute, at most, to implement it, and just as fast to remove it if it does not work.

Why don’t you try it?


I think I would use this .htaccess snippet:

RewriteEngine On
RewriteRule (.*) /wordpress/$1 [L]

By doing this, you’re not redirecting your site to the subfolder, but rewriting it instead. So you can actually view your pages without /wordpress/ in the URL.

But to be clear: this is a dirty hack. Moving the files is the right thing to do.

You don’t need to reupload anything. Just move the files. In this screenshot from FileZilla, just select all the files in the bottom panel, then drag them to the htdocs folder in the top panel.

Moving files is done entirely server side, so no need to transfer all your files. So it only takes a few seconds to move everything.

No single web request should ever consume that much memory. 512 MB is enough to fit the entire WordPress codebase into it 8 times over.

WordPress, by default, just uses a premade theme that contains the design (whether that’s a standard theme, third party or custom made), and populates it with the pages and posts you write.

Elementor is not a basic thing. A fully featured drag and drop web page builder is a ridiculously complicated piece of software compared to what WordPress can do by default.

Also, even Elementor’s system requirements say that 128 MB is enough. So I don’t know what makes you believe that we need to change server settings to fix your site: System Requirements To Use Elementor | Elementor

The article does mention a 512 MB limit, but that’s if you use Elementor and WooCommerce on the same site. Both of those are very heavy plugins, and a site with both of them definitely won’t run well on free hosting.

Elementor also knows this. While WordPress itself is 100% free and open source, Elementor pretty much only ships a trial version of their builder for free. If you want more, you need to pay them at least $49 per year. And that’s just for the builder, you don’t even get hosting for that.

Also, where and how do you suppose we should communicate this? We just provide web hosting for free. Many people use it for things that are not WordPress, or don’t care for Elementor. If you were to write down all the things that are probably not a good idea for free hosting, you could fill many pages, and nobody would read that. Anything you install on your website is your responsibility. It’s not like we can show a warning message next to Elementor in your WordPress admin warning you that it may not run well.


I have introduced the following into my .htaccess file:

Yet I still can’t get my landing page or WordPress login to display from my linked submitted URL,

Can someone have a look at my account and my case to see what is going wrong?

My account email address is HIDDEN BY [email protected] .

1) How do I get my WordPress login to come up, given that I want to use .htaccess wrangling to adjust directory detection for the Web Server?

2) How do I get my website landing page to come up, given that I wan to use .htaccess to acheive a similar effect?

I checked the files in your account.

Please remove the .htaccess code from the .htaccess file in the wordpress folder, and instead create a new file with the name .htaccess in the htdocs folder itself and put the code into it instead.

Please note that the server checks the .htaccess file in the folder you’re navigating to, and any parent folders. So seeing how you want to redirect requests for the main htdocs folder, putting rules in the wordpress subfolder will not work.


I moved .htaccess, and am now encountering the following error when trying to see my website,
at its domain name:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at [email protected] to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

What is going on? Is this something simple that I can fix, or does InfinityFree need to repair it at its end?
Can someone over there tell me how to easily fix this, or, hopefully, do so themselves, kindly, please?

This is what I see



I apologise. That’s my typographical error. It’s . I’ve changed it above where I first tried to include it as well.

At any rate, why is my website not displaying (bear in mind I have used an edited .htaccess file)? Or do I have to wait some amount of time for the internet to pick it up, and that alone is the problem?

OK, so apparently my .htaccess code doesn’t work, sorry about that.

I can’t think of any .htaccess code that would work. Feel free to try other codes to try and make it work, I can’t do much to help you.

My recommendation, which I know for sure will work, is still to just move the files to the htdocs directory. It’s fast, simple and effective. I still don’t understand why you insist on going the .htaccess route.

Feel free to try other ways, but no guarantees it will work.


I have found that if I go to:

I get the following image:

-How can I get rid of the /wordpress/ suffix?

-Why am I getting this distorted error screen? Does anyone know why I can’t get my desired landing screen to load first, and not this screen?


Your WP installation is likely messed up.
All your paths and links are wrong
Page still not loading after more than one minute


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.