My website is going to " not secure connection… "

Hi everyone,

I’ve seen my website ( ) is going to " not secure connection… The website doesn’ t trust… Taking the risk " it opens.

So I checked the certificate and it was noy looking like other times, in the account of infinity free I can see is issued and installed but on the cp looks to configure… (I did it manually and was ok)
So I uploaded key and certificate again , good idea? Cause after the direct link from the account section of infinityfree was working, now I see they work also both the website and the website admin login page…
But what’s the point with gogetssl… Is there something to fix or doing differently… It has just a couple of weeks… And it happened already before …

I add that the web was noticing a self signed certificate, that shouldn’ t be cause I manually configured the goget ssl certificate, so I checked and was really to configure again…

I hope there are good tips

I’ve split your posts to a separate topic. Just because someone else has a question about HTTPS and your question is also about HTTPS, it doesn’t mean the issue is the same. And if the issue isn’t exactly the same, please create a new topic.

As for the issue itself, I just checked your site and I see the GoGetSSL certificate. Can you please check if it’s working for you now? And if it doesn’t, maybe check it in Incognito Mode as well?


Hi, thanks , ok, right.

I checked and at first the website made the same, while the admin login page of WP loaded good, the second time the website loaded good too.
Like yesterday after the re-uploading of key and certificate was running ok.

My doubt is about what’s up to the certificate that is installed ( I copied and pasted the key and certificate checking all details and the installation was succesfull) and somehow sometime looks going apart, like erased? Or splitted in some other mode…?

Hi everyone,

I write here cause is related and i don’ t find my last post… Also related…

Stll about the certificate installation…
I tryed the automatic installation of ssl and manual too… (Checking that was succesfull)

But looks like splitting in self signed certificate that gives error or warning for unsecure connectipn…

What do you suggest to secure the configuration of the certificate? The httacces file setting up following your instructions?
(Forcing visitors to https…)

I checked last time and I just checked again, and your website is currently using a GoGetSSL certificate. There are no traces of any self signed certificate anymore. If you do see it, then it’s probably caused by certificate cache on your end, which you can circumvent by checking your website in Incognito Mode.

You shouldn’t ever have to touch the private key or certificate yourself. The automatic SSL installation can handle the installation for you. Rest assured it has been used successfully many times by many people, so no need to second guess it or check it yourself unless you see any issues that could be caused by it.

WordPress is already forcing everyone to HTTPS, which means you don’t need to do anything else if you don’t want to. But you could also setup a forced HTTPS redirect in your .htaccess file, which can help a little bit for performance and server load.



Thanks so much for your clear replay.

So the “page introduction” below, in the ssl field of the cp, what does it mean? That is installed and configured a signed certificate or a self signed default one?

The TLS / SSL manager shows you sites that have SSL enabled on them.

You can below configure a ‘Signed’ certificate for your website.

The default SSL is a Self Signed Certificate.

Clicking ‘Configure’ below allows a signed certificate to be activated.

|Site URL| Configure SSL | Upgrade|

||| [button to CONFIGURE SSL] | [button to UPGRADE]

I made it automatically the first 2 times but when I’ve seen the website was troubled I checked the cp ssl section and it looked me different …
Is it possible the ssl page looks different suddenly after the certificate succefull installation? I don’t remember exactly how it was, I think under : ssl certificate there was a long text … The certificate I guess,
and the first phrase about: " your website has ssl enabled… " was missing …

Please I hope you can add details about it, thanks

The first phrase was missing not after the installation but after issues on the web

This is new website, and I want avoid that kind of issues…

Do you think this website could use let’s encrupt?

Thanks again

Just choose the Recommended CA when creating the SSL, and use the automatic validation and installation tool


That message is no longer true. There used to be a default self signed certificate in the past, but that’s no longer the case. By default, there is no certificate at all right now, so you’ll need to get and install one yourself, even if a self signed certificate suffices.

No, it isn’t. The SSL/TLS page is the control panel always looks exactly the same, and has done so for many years as far as I remember. The only thing that changes is the list of domains you can install SSL for, and the contents of the private key, CSR and certificate boxes.

I think that if you need to ask, you probably shouldn’t choose your own SSL provider. It’s called an “Advanced Option” and hidden by default for a reason: most people shouldn’t touch it.


I know that all the choices and sections and configurations can be confusing and overwhelming and cause a lot of questions. For this reason, we have the Free SSL Certificates tool. It’s so you don’t have to think about certificate installation, managing DNS records, choosing SSL providers and so on. Just enter your domain name in the box, and basically keep clicking the big buttons to continue.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.