Multiple sites having database connection errors

Account: epiz_33176776

Error Message

Wordpress simply says:

Error establishing a database connection

After enabling debug, it seems that something is wrong with the connection details:

Access denied for user ‘33176776_1’@‘’ (using password: YES)

Other Information

I’ve done three fresh installs of Wordpress and tried to set up a network using the subdirectory method.

The first time, the error was displayed immediately after installation.
The second time, I installed the normal version of Wordpress and manually set up a network. It worked for a couple of minutes and displayed the error.
(The above two attempts where on the same domain ( which I deleted, but the hosting account is still active( epiz_33176442)

The third time I set up a new hosting account and a new domain and used the multi-site option in the installer, and everything worked for about ten minutes and I suddenly got the error.

I have tried changing database the user and password to the one of my account instead of the user Wordpress created, but that didn’t resolve the problem.

Since the website takes some time to be broken, is it because that I am being suspended from the SQL server?

P.S. PMA just does not load, it says something about too many redirects. I have not changed my hosting password, also FTP works fine.

Read again


Thanks, but I did specify that

  1. Wordpress was installed using Softaculous and was working perfectly fine until it didn’t. In that time I didn’t touch a single config file. All I did was do stuff in the dashboard.
  2. It seems that Wordpress has its own sql user. I replaced that with the credentials of my hosting account. I also made sure that nothing was wrong with the database name and hostname. The dbname seemed to be always right, but Wordpress was using instead of I changed it but this did not resolve my problems
  3. It seems PMA just refuses to work. I have not changed my hosting password.

To summarize, following the instructions in your article did not solve my problems.

You did, because you


I changed the config file after the problems appeared. Just as a reminder, it did not work.

Hmm, I checked the database and it doesn’t seem to work in phpMyAdmin as well. So I think something weird happened with the database or the permissions.

Given that the account is only a few hours old: does the database have any content that’s worth keeping? If not, the easiest solution is probably to just remove the WordPress installation and start over.

Most likely whatever happened here was a random issue, so by reinstalling you should get a fresh database with correct permissions.


As I said, I have already tried that. It did not work. I believe it might be something specific to my infinityfree acount.
P.S. I am out of hosting accounts so I cannot try again.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.