Maximum upload size is 0 bytes

I am getting this error while uploading file.
It says
'The following items exceeds the maximum upload size allowed(0B) by your server configuration'

I tried to add one add on domain and upload source files, after a few file upload it showed error 502 bad gateway. Then I removed add on domain and added one parked domain. The domain is working fine but when I try to upload any file this error shown

The maximum upload size on our servers are 10 MB. What software says the limit is 0 bytes? Is it a web based file manager? One which we provide or one which you uploaded yourself? Or a desktop FTP client?

I was using Monsta FTP for uploading it was showing this error in the above URL.
I had also tried online file manager which showed 404 page when file was selected and didn't uploaded anything.

I deleted all files of the htdocs folder of addon domain and little while after deleting it, the upload started working. But please can you look into the matter and explain why it happened?

Sure, I can look into it. On which account did you experience this issue?

epiz_23055083 That’s the username of the account

I can't find any clear data to prove it, but I suspect the issue was caused by hitting the inode limit.

On free hosting, you can have up to 30,000 files and directories per account. If you have more files than that, you are unable to create or upload any new files.