Keep getting connection not secure on website

Hey there, hope you all are having a great day! So i have a forum on InfinityFree and whenever i log in or post something it ends up showing this: The connection for this site is not secure sent an invalid response. I have a free SSL certificate installed and my website forces https, could that be the issue?

Website link:

heres a image of the issue

Your website works fine for me:

On your screenshot though, I see you’re trying to access it through port 80, which is the HTTP port, and as such throws an issue.
This seems to be an issue with your phpBB configuration, this thread may help:

Quoting from there:

By default, phpBB assumes you will be using HTTP, not HTTPS. Once your certificate is installed and tested, it’s easy to change phpBB in the Administration Control Panel: ACP > General > Server configuration > Server settings. Then change server protocol from http:// to https:// and the server port from 80 to 443. What this does is change the links across the site.

None of these settings should be relevant or necessary, unless you have the “Force server URL settings:” configuration in that same section set to “Yes” . Presuming that the “Force server URL settings:” configuration set to “No” on your board, the “Server port:” and “Server protocol:” and everything else there was already being ignored before you enabled HTTPS, and will continue being ignored now after you enabled HTTPS.

If you have some issue or condition on your hosting provider that requires that you do have the “Force server URL settings:” configuration set to “Yes” , then indeed you must change the configuration as described, or else phpBB will continue writing non-HTTPS URLs for board links when rendering pages.

If you already have “Server protocol:” set to “https://”, the recommendation for “Server port:” is to leave this value completely blank. Specifying a port value is for when “my server isn’t running on a standard port”, such as HTTP over 8080, or HTTPS over 9008, etc. If your server is using the default port for the specified protocol, it’s just a waste of space and making your URLs ugly to require that “:443” or “:80” be appended to the DNS name in all your links.


Alright! I’ll try that once im back on my computer, I had to go somewhere Thanks once again!


Thanks a lot! It worked :smiley:


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.