JavaScript not loading

Hi, my classmates and I have developed a website for our client and the website works on our localhost and we have used relative links to work with InfinityFree hosting yet our website will still not load the JS files for whatever reason and we are unable to figure it out. Please advise.

Our link is:

Hello there,

What JavaScript files did not load exactly? as far as what I can tell your site is working fine on my end.

Are you able to open the slide out menu? the website should look like this… Connection denied by Geolocation

The main.js file is not called

That link did not work.

Oh, nope I can’t open the slide menu actually.
Try using F12 Developer Debugger mode to check if something is wrong with your code.

I run and test your site with the Developer tools and it seems like there’s a problem with your code.
This is the error:

This is the solution and info it provided me on how you can fix it:

Sorry. That’s my bad./ the link is:

I looked in the console and saw that that was an issue, yes. I fixed it and it still doesn’t access some of the js files

What other JS files are not working exactly?
Your menu bar works fine now.

Hi! I’ve just been fixing it. Found out that my teammate made a booboo and deleted a load of important code from the JS. Thank you for all of your help.

I do have one more issue though. Do you have any idea why the pentagon buttons don’t appear in safari for Mac or iOS? But they do on my dummy server previously mentioned

Hell there,

I don’t really have an iOS to test your site but it may be because the browser doesn’t support it which is unlikely since Safari is a modern browser.

Also I was curious why your previous reply got flagged. I might have accidentally flagged it since my device was being laggy but not sure if I did.

Thank you for being so cooperative and helping me out :slight_smile:

I have managed to narrow it down to the mask I have on the pentagons. Again though, like you say… it’s not like it isn’t supported, Safari is a modern browser. Plus, it works on my dummy server. I’m thinking maybe it has something to do with InfinityFree hosting.

Oh, I’m not sure why it got flagged. I think it was because I posted another link and it didn’t seem to like it, but when I got rid of it, it let me post it. Strange.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.