JavaScript files are not updating!

I have did some changes but it’s not live, I cleared cache, hard reload even tried in private tab. Please give me a solution

Well, since you did not disable server caching, this may help

<IfModule mod_headers.c>
    Header set Cache-Control "no-cache, no-store, must-revalidate"
    Header set Pragma "no-cache"
    Header set Expires 0

<FilesMatch "\.(css|flv|gif|htm|html|ico|jpe|jpeg|jpg|js|mp3|mp4|png|pdf|swf|txt)$">
    <IfModule mod_expires.c>
        ExpiresActive Off
    <IfModule mod_headers.c>
        FileETag None
        Header unset ETag
        Header unset Pragma
        Header unset Cache-Control
        Header unset Last-Modified
        Header set Pragma "no-cache"
        Header set Cache-Control "max-age=0, no-cache, no-store, must-revalidate"
        Header set Expires "Thu, 1 Jan 1970 00:00:00 GMT"

Add the above to the .htaccess file.
Once you can see the updated content, remove the above statements as it will affect server performance. This is not a long term solution as you may hit suspension easily.


what ?

Without caching you are overloading the server more frequently.
That’s why I said add this code at the bottom of the .htaccess file to turn off caching.
Once you can see the changes, delete the code to turn caching on again.


This code even not updated

Are you using CloudFlare?

1 Like


What is the URL?
Next time please fill in according to the template.
Without info, it’s like searching for a needle in a haystack…


FYI: there is no server side caching, and the .htaccess codes you’ve provided control client side caching. But if you’re checking the page in private browsing mode, then all browser level cache should be bypassed entirely.

Could you please share a URL of a file that is not updated, and clearly point out what the code is in the updated file, and what code you are seeing on the website? The more specific you are, the better we are able to investigate. “The server is not updating” doesn’t give us a lot to go on.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.