Issue regarding CNAME records not taking effect

Website URL

Error Message

Not applicable.

Other Information

We’ve set the CNAME records (by using InfinityFree’s automatic CNAME record setup), and we have been waiting for them to take effect. It has been a long time (past an hour), and it appears to be stuck on “Not Ready.”

The “Request Certificate” button remains grayed out. We have tried deleting and remaking a certificate order, but to no avail. We have tried messing with CNAME records manually, to no avail. We have checked our domain registrar, and they’ve said that, because we are using InfinityFree nameservers, DNS records are managed by InfinityFree.

We dug through some old topics recommended after the title of this topic was written, but found nothing helpful. We would greatly appreciate the help.

Much appreciated.
– Kai

That’s not a ‘long time’. DNS records can take up to 72 hours (3 days) before they propagate. Messing with the records and the certificate probably just made everything worse.

Create a new certificate, add the CNAME records, and just wait for it to be verified. It may take an hour, it may take 2 days.


We were mislead by the phrasing of the success message, stating “Please note that it may take up to an hour to take effect due to DNS propagation/caching.”

If this statement is incorrect, and further waiting is necessary, then we will try that. If this continues further, then we will reply once more.

– Kai

Well this is an awfully strange occurrence.

When the certificate was installed, it says it has expired already. Looking at the time in the Step 5 category, it states that it had expired yesterday. Looking at the Step 4 category, however, it states that it will expire June 24th.

If this happens to just be another oddity whereas waiting is the solution, then I wish it’d at least be more clear. Unless if this is not just a regular occurrence. A friend of mine, who’s used InfinityFree for a long time, said he’s never seen anything like this happen.

– Kai

The data on the screenshot you’re showing is correct. The SSL certificate mentioned on Step 4, the certificate you recently issued, is set to expire on the 24th of June 2024, whilst the certificate that is currently activated in your site, displayed in Step 5, has already expired 2 days ago.

If the new certificate is ready, there should be a button to install it below the Step 4 box:


Ah, yes. Thank you. I greatly appreciate your clarification.

– Kai


The DNS caching in the CNAME verification check should be pretty minimal, and under good circumstances it should take way less time than an hour. But please understand that DNS caching can be unpredictable, and it can take longer than that.

While DNS caching in general could take up to 72 hours in bad circumstances (and even longer if it’s really bad), the tuning on the CNAME record check should be a lot faster. Almost all of them should be visible within a few hours, not days. But again, it’s unpredictable.

Also here: it’s caching. It can take up to 15 minutes for a new SSL certificate to become active, and the SSL installation status shown in the client area is also not updated immediately. I would say the worst case scenario would be 30 minutes, but usually only a few minutes at most.

That is of course under the assumption that the new certificate was actually installed, not just obtained.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.